This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

ClockPro Hang

Other Parts Discussed in Thread: CLOCKPRO, TUSB3410

I am having issues with getting ClockPro to run properly with my CDCE EVM board.

My EVM board is one of the first releases I think back in 2009. 

At that time I loaded the first version of the sw but that was removed and so I had to update to the latest.

I just downloaded the SW and Drivers to my XP machine, unzipped the drivers in a folder.

I used Windows wizzard to find the unpacked drivers however it won't load them from this folder.

Instead the Win Wizzard finds one in the windows driver directory, perhaps the original driver or something inappropriate, I think this is the problem.

Q - Why can't it pull the new driver out my folder?  Is there some ID problem on the EVM?

I checked the Device Manager and see that the EVM calls it self TI CDCE(L)9xx Family_EVM-Serial Port.

Using the driver found in Win system, I ran the SW install and noted the installation of .Net framework 4 and TUSB3410.

I found another string on this topic and his EVM is calling out TUSB3410.

Q - Do I need to get the latest board?

When I run the SW and try to have it find the board I get an Exception warning and the SW crashes

Top line says:  Index was outside the bounds of the array.  at CDCE949Project.ProgramminEVMDevice.GetFirmware Veersion (Boolean& is1p1)  Etc - see below

This happens with the EVM board connected or not. Whe the EVM connected to USB and initialiation of the SW, the Green circle stays dark.

I assume I have the wrong driver but don't know how to resolve this



    This string is similar to

    It talks about reprogramming the EEPROM memory on the EVM

    Please follow this instruction:6644.TUSB3410 EEPROM Burner

    • install driver from the attached zip file.
    • execute eepromburner.exe
    • select "TI TUSB3410 EEPROMBurner” and a eeprom size of 64kbits (this is important!!!)
    • click on browse and search for cdcproevm.bin from the zip file
    • click once on Programm EEPROM and wait a few seconds till a window pops up that says 'programming success full'
    • close eepromburner software and reconnect EVM
    • install driver from the previous post if needed

    I gave this a try but the eepromburner.exe finds my EVM named as "CDCD(L)9xx_Family_EVM-Serial Port" only - Not the TUSB3410 selection above.  It also can not write to the EVM even if I select my only named option. 

    Note that my CDCE EVM is an older unit from ~ 2009 but the EVM HW looks identical to the picture of the EVM in the latest EVM data sheet and it does have a TUSB3410 USB interface chip on it.

    I am now assuming that I can't get this older CDCE EVM to work with the new ClockPro. 

    Yesterday I ordered a replacement unit as my contingency plan and hope it shows up soon.  (free ship is nice but I'd rather have the option to expidite)