This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

TLA2024: Does not work when I2C pullups are at 5V and the VCC is at 3v3

Part Number: TLA2024
Other Parts Discussed in Thread: ADS1015,


We are currently using an ADS1015, due to a low supply we would like to change to a TLA2024. 

In our circuit this chip is powered by 3v3 and the I2C bus has 4k7 pullups to 5V. The old chip(ADS1015) worked like this without any problem. The new one (TLA2024) does not. 

If i lower the I2C bus voltage to 3v3 the TLA2024 works (power == 3v3 and bus level == 3v3) 

If i increase the power to 5V the TLA2024 works (power ==5V and bus level == 5V)

it just does not work when the bus is at 5V and the chip is at 3v3. 

Unfortunately, i cant change this in the product.

In the datasheet it does not say the I2C bus should be at a certain level from VCC. It just says GND to 5.5V. 

Do you know if this chip shouldn't work like this?

Thanks in advance

  • Hi Niels,

    Can you clarify how the TLA2024 isn't working in the case of VDD at 3.3V, and the I2C bus being pulled up to 5V? Are you just unable to communicate with the part through I2C? Is there any acknowledgement to commands and bad data, or just no response at all?

    How is the address pin configured, and are there any other TLA2024s on the I2C bus?



  • Hi Scott, 

    Good news, it looks like it is working now.

    The device did not respond to any I2C commands when the I2C bus was at 5V and the VCC at 3v3. On the address of the device which is 0x48, the device always responded with NACK, so it did not respond at all. Other devices on the same bus responded without any problems. There is only one TLA2024 on the bus. 

    I have removed the IC and resoldered it, now it works, so it might have been a bad solder connection. I still do not get why it did work at a 5V VCC and 5V I2C, and also at 3v3 VCC and 3v3 I2C, but NOT at 3v3 VCC and a 5V I2C bus. This was tested multiple times. 

    I am still going to do some more test, but it looks like this issue is resolved.