This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

ADCPRO: 1278

Part Number: ADCPRO


I have been trying to collect some data from ADCpro1278 via ADCpro software tool installed in laptop and facing issue in acquiring stage (i.e when I hit the button on acquire).

The issue is whenever, I plug in USB cable to laptop  - (at first in device manager it shows NI-VISA and then --> USB-styx --> suddenly at some point it disappear soon) and when I trying to start acquiring the data it throws an error below. 


So far from the error code,this tips I found out from the TI forum answer given by Andrew check this post ((+) ADS1278: Timeout errors when connecting EVM to ADCpro - Data converters forum - Data converters - TI E2E support forums).

I felt that it might be a driver problem and I tried to solve it via doing some steps mentioned here (only first one tried so far - Top 2 Ways to Disable Driver Signature Enforcement on Windows 10/8.1/8/7/XP/Vista | Driver Talent ( but did not worked.

So my question will be what can be done in this situation ? Is something wrong with my driver if yes then how should I update? if it's driver related problem. If not then any suggestion will be appreciated :-)

  • Hello Vikas,

    Welcome to the TI E2E community.

    The older E2E links were created before the ADCpro drivers were updated.  ADCpro now have signed drivers, so these should install correctly on Windows 10.

    The drivers are included in the ADS1278EVM-PDK-SW plug-in.  I suggest uninstalling all software, including ADCPro as well as the ADS1278EVM-PDK-SW.  When you are ready to reinstall both software packages, make sure the EVM is not plug into a USB port.  Also, you should have ADMIN privileges to ensure the drivers and related software are installed correctly.

    Although I do not think this is an issue based on the error report, you can disable the EEPROM check for the EVM.  The EVM will still work correctly, but this will be one less step that you need to get through for proper operation of the GUI.  

    You can find the details at the end of this E2E thread:

    Keith Nicholas
    Precision ADC Applications

  • Hi Keith,

    Thank you very much for your quick response.

    I have followed your instruction carefully (i.e, re-install drivers and ADCpro software from scratch) --> it worked only the first time (one time), and then when I try again connecting them and acquiring the data, it throws a bunch of errors (different error while doing multiple times - even doing the same thing, for example, taking out the USB and putting back and starting to do again and so on). 

    What could be the reason for the attached errors? and why? 

  • Hi Vikas,

    It appears that the USB-Styx driver is no longer installed.  Can you confirm that it is not installed correctly under 'Device Manager'?

    If it shows up as unknown device, you can follow these steps and manually re-install the driver.  You will want to leave the EVM connected to the USB port so you can manually install the driver.  Once it is installed, disconnect the EVM (and remove power), then reconnect everything.  Hopefully, it should now work!

    1. Open "Device Manager" and locate the "Unknown Device".
    2. Right click on the "Unknown" device and select "Update Driver Software...".
    3. Follow the prompts and make sure to select the following options:
      1. "Browse my computer for driver software"
      2. "Let me pick from a list of device drivers on my computer"
      3. "Show all devices"
      4. "Have disk"
    4. When asked for the location of the driver browse to the MMB0 driver folder, which should be located at
      C:\Program Files (x86)\ADCPro\drivers\usbstyx
    5. Select the "usbstyx.inf" file and click "OK".  (This is the new signed driver required for Windows 10)


  • Hello Vikas,

    There is one other possibility.  You had mentioned that the EVM will initially work, but then at some point, it stops working.  If the power to the EVM is temporarily interrupted, the USBstyx driver will stop working, and you will get the 6004 error, which indicates the driver is no longer working.

    Please verify your external supply is set to the appropriate values:

    Connect power to the MMB0 board. If power is supplied from an AC adapter (not included), ensure that it satisfies the following requirements:

    • Output voltage: 5.5 VDC to 15 VDC (If set to 15V, this may cause over-heating of the regulator, suggest setting to 6.5V max.)

    • Maximum output current: ≥ 500 mA

    • Output connector: barrel plug (positive center), 2.5-mm I.D. x 5.5-mm O.D. (9-mm insertion depth)

    • Complies with applicable regional safety standards