This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

TSW14J56EVM: ADS54J66 Interfaced to TSW14J56, Unable to capture

Part Number: TSW14J56EVM
Other Parts Discussed in Thread: ADS54J66, , LMK04828

Hi,

To evaluate the performance of ADC Module ADS54J66, i have procured ADS54J66 + TSW14J56 Combo

I have biased both of the boards with 5V/4A(CurrentLimit) Supplies 

Connected both of the boards USB to my PC

Ran the HSDC Pro V5.2

Below is the screen shot of errors i recieve, kindly let me know where exactly i am doing wrong

By the way the User manual of EVMs are very old, i could not find the said ADS54J/58J6X GUI at all

Kindly help.

  • Hi Shyam,

    You can find the ADS54JXX GUI here:

    https://www.ti.com/tool/ADS54J60EVM

    Under ‘Order & Start Development’ there is a section called ‘Hardware and Software Package’. Select ‘View Package’. At the bottom of that tab there is a section called ‘Software Development’, where you can download the ‘ADS54JXX EVM GUI’.

    The error you are seeing in HSDC Pro is likely due to the capture card not receiving the clocking signal. Please ensure that the correct configuration files are used to configure the part.

    Regards, Amy

  • I am not really configuring anything, i am just selecting the ADC and fimware is loaded automatic, can you please let me know which is the correct config / firmware file to be programmed if to be done manually ?

    the process i am doing is as follows

    1. Load Config file to ADC board via USB using ADS54JXX GUI

    2. Reset the ADC Board

    3. Open the HSDC Pro and done following to see whether capture is working, still same issue

    I am giving a Input sine waveform of frequency 80Mhz

    As per EVM User guide

    D3 – Indicates ADC EVM established SYNC with the TSW14J56 device when off
    D4 – Indicates presence of device clock from ADC EVM when blinking

    In my case D3 is ON and D4 is OFF and not blinking

  • Shyam,

    There is a bug in the firmware file used by HSDC Pro GUI. Please replace the file called "TSW1456REVD_RX_ALT_SYNC_LVDS_FIRMWARE.rbf in the directory shown below with the attached file. Unzip the file before replacing it.

    Regards,

    Jim

    TSW14J56REVD_RX_ALT_SYNC_LVDS_FIRMWARE.zip

  • I have tried to replace the file and repeated the process

    i assume there is some problem with the LMK_Config_LMF_4841_491p52_MSPS.cfg file, is this file updated ?

    can this be used for boards ADS54J66 ?

  • There is no problem with the config file. What two config files are you loading? Are you pressing the ADC reset switch after loading the LMK config file? Please send the status of the LED's on both boards when you have the issue.

  • As per EVM User guide

    D3 – Indicates ADC EVM established SYNC with the TSW14J56 device when off
    D4 – Indicates presence of device clock from ADC EVM when blinking

    In my case D3 is ON and D4 is OFF and not blinking

    On ADC board D3 Lits up as a sign of PLL locked.

  • Shyam,

    Are you issuing the ADC reset? Have you tried other configuration files such as bypass mode? Please report the status of ALL LED's on the TSW14J56EVM, not just D3 and D4. What is the version of the TSW14J56EVM?

    Regards,

    Jim  

  • To Clear Again, File being programmed is LMK_Config_LMF_4841_491p52_MSPS.cfg via ADC GUI.

    Let us know clearly what clocks need to be checked ? i have verified JESD Clocks and they are ok,  On ADC board below are not generated from LMK04828

    1. SYSREFP not  being generated
    2. CLK_LAO_0P not being generated
    -----------------
    On ADC board only D2 and D3 are high
    on FPGA board when firmware is loaded only D3,D8,D10,D17,D28 are glowing remaining all LEDs are off

    ------------

    Screen shot of registers readback from ADC after reset button is pressed

    my presumption is wrong configuration file being dumped

    Version of EVK Boards which are shipped to us are 

    ADC Board : S/N 6230900011 Rev A

    FPGA Board : S/N 4246100125 Rev D , i also see a sticker T8133FtD

  • What do you mean by SYSREFP is not being generated and CLK_LAO_0P not generated?

    Please try bypass mode. Is rest pressed after loading LMK but before loading ADC?

    What is TSW revision? 

  • my presumption is wrong configuration file being dumped

    Version of EVK Boards which are shipped to us are 

    ADC Board : S/N 6230900011 Rev A

    FPGA Board : S/N 4246100125 Rev D , i also see a sticker T8133FtD

    I am not sure whether SYSREFP and CLK_LAO_0P  clocks to be generated from clock generator of ADC but they are not active / no signal

  • Please try other modes shown in attached document. If none of these work, you may have a bad board.

    7206.ADS54J66EVM Quick Startup Guide.docx

  • we have tried other modes also no use, is there any diagnostics tool which i can run give you a report to decide on rejecting or accepting the item ?

  • Shyam,

    In HSDC Pro GUI, after connecting to the EVM and selecting the ADC mode "ADS54J66_LMF_4841", click "No" when asked if you want to update the firmware for the ADC. Next click on "Instrument Options" in the top left of the GUI, then select "Download Firmware". Go ahead and select the file attached after you unzip it.

    Regards,

    Jim

    TSW14J56REVD_ADS54J66_FIRMWARE.zip