This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

ADC32RF45EVM: clk0 and clk1 clock zone divider only stays at 32

Part Number: ADC32RF45EVM
Other Parts Discussed in Thread: TSW14J57EVM, LMX2582, LMK04828, ADC32RF45,

I am using this ADC with a TSW14J57EVM board. And i was trying to use internal clock LMK2582. I programmed ADC EVM board with settings as:

Nyquist - 1st zone

Clock - LMK2582 to ADC

Sample rate - 1536 Msps

mode - bypass and 14 bit.

then i programmed the EVM. After which i tried changing the divider from 8 to 16 but it automatically changed itself to 32 and now i dont know what am i doing wrong can you help me with this.

  • Hi Pavitra,

    I have noticed this most often occurs when the LMX2582 device:

    1. Is programmed with an incompatible register sequence
    2. Does not have a reference clock input. It is possible that the LMK04828 (which is buffering the 122.88MHz oscillator to the LMX2582) has the OSCOUTp/n disabled, preventing the reference to the LMX2582). Check this on the LMK04828 PLL tab.
    3. LMX2582 has not been calibrated (register 0, bit 3 = 1) at the end of its programming sequence.
    4. Or I think the main factor contributing to this issue is the GUI itself. Sometimes upon a read all action, all of the LMX2582 and the LMK04828 fields will show <32>.

    To avoid this, I suggest to load a configuration file. If you want, I can create a 1536MHz output frequency configuration file using TICS Pro and then convert it into the appropriate ADC32RF45 GUI format for you. If you are interested in this, please let me know.

    Thanks, Chase 

  • Yes if you can provide GUI for this then it will be very helpful. If possible can u also add instructions to use it along with it.

  • Pavitra,

    The GUI is called TICSPRO ( Choose the Select Device tab and choose PLL+VCO, then choose LMX2582. This should pull up the LMX2582 GUI. We typically use this to generate the registers for any of our clocking parts. However it is important to note that the format of the register text file is different than what the ADC32RF45EVM GUI uses, so you must reformat into the correct format. Try this configuration out. It's always possible that the one included in the ADC32RF45 folder is non-functional.

    0x00 0x0x02
    0x00 0x0x00
    0x46 0x0000
    0x45 0x0000
    0x44 0x0089
    0x40 0x0077
    0x3E 0x0000
    0x3D 0x0001
    0x3B 0x0000
    0x30 0x03FC
    0x2F 0x00CF
    0x2E 0x1FA3
    0x2D 0x0028
    0x2C 0x0000
    0x2B 0x0000
    0x2A 0x0000
    0x29 0x03E8
    0x28 0x0000
    0x27 0x8204
    0x26 0x002E
    0x25 0x4000
    0x24 0x0411
    0x23 0x021F
    0x22 0xC3EA
    0x21 0x2A0A
    0x20 0x210A
    0x1F 0x0601
    0x1E 0x0034
    0x1D 0x0084
    0x1C 0x2924
    0x19 0x0000
    0x18 0x0509
    0x17 0x8842
    0x16 0x2300
    0x14 0x012C
    0x13 0x0965
    0x0E 0x018C
    0x0D 0x4000
    0x0C 0x7001
    0x0B 0x0018
    0x0A 0x10D8
    0x09 0x0302
    0x08 0x1084
    0x07 0x28B2
    0x04 0x1943
    0x02 0x0500
    0x01 0x0808
    0x00 0x2218

    Thanks, Chase

  • Sorry to not mention this beforehand but it was not like it never worked. It sometimes work fine and sometimes show the problem i mentioned above. So i dont know what is i am doing differently which is causing this error

  • Hi Pavitra,

    I'm not sure if there is any particular reason as to why the graphical issues occur, so when this happens I suggest to just reset the GUI and powerdown the device before reconnecting, if applicable. It's good to know that it does work sometimes. Is there any pattern at all as to when it works? Such as loading a configuration file for all of the devices at once? I suggest to get the EVM in a functional state, press the Read All registers button (which may take a minute or so) and then press the Save button to save the configuration.

    Thanks, Chase