This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

DAC3283EVM-SW: DAC3283EVM-SW will close GUI when click on Reset button

Part Number: DAC3283EVM-SW
Other Parts Discussed in Thread: DAC3283EVM

Good day.

Due to PC upgrade in my lab, I have installed DAC3283EVM-SW in windows 10.

At first, GUI worked fine and I was able to reset and initialize DAC.

However, after I restarted PC, GUI will close when I click on the reset button.

Can you kindly advise how to resolve this issue? Thanks in advance!

  • Hello Doreen,

    I recommend that you right clock the executable and run the executable as an "administrator" mode and check the if the problem still persists. I do not believe this is a Windows 10 issue as I have seen the software works in our windows 10 environment. Please also check if there are any anti-virus program running that may stop the executable.
  • Hi Kang,

    I tried running as an administrator -- the problem still persist.

    There is a warning message flashing
    - Device communication failure, Check USB cable connection and Press "Reset USB Port" Followed by "Read all"

    Is there any USB device that could potentially conflict with DAC3283EVM? I am using this DAC with Xilinx VC707.


  • Hello Doreen,
    let me check again on my WIN10 PC. Perhaps there is another patch being released by Microsoft that prevent the GUI from opening.

    The DAC3283EVM uses FTDI chip as primary connection to the USB port of the PC. One thing about this is that the FTDI chip is *not* enumerated so it may be generic ID as other FTDI chip. If the programming pod of the Xilinx VC707 also uses FTDI chip, the two programs will conflict each other.

    It is best to remove all other devices from the USB ports of PC, connect only DAC3283EVM, start the GUI, and connect to the GUI by pressing the reconnect USB button. Then, you may start connecting other USB devices one-by-one.

  • Doreen,

    I had verified that the DAC3283EVM GUI works in WIN10 environment. All the latest WIN10 software patches were installed.

    I recommend that you double check and remove all other USB devices such as Xilinx programmer pod to avoid potential FTDI bus contention

    you may also download the FTPROG utilities from FTDI website to scan for FTDI usb chips on your PC. If you can see the FTDI chip from the DAC3283EVM with the FTPROG, we can eliminate hardware issue.
  • Hi Doreen,
    I have not heard back from you on this issue. I will close this post but you may respond back if further support is needed
  • Hi Kang,

    Sorry for the late update.

    I found that there is USB confilict between Xiinx VC707 JTAG programmer and DAC3283EVM. When I removed the USB port connection for Xiinx VC707 JTAG programmer, DAC3283EVM works fine.

    However, I have another test setup on PC with WIN10 and it works fine with both USB ports connected.