This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

ADS112U04EVM: Delta-Sigma ADC Evaluation Software: Unable to Identify device = ADS112U04

Part Number: ADS112U04EVM
Other Parts Discussed in Thread: ADS112U04, ADS122U04EVM, ADS122U04

My setup:

I cant see the registers of the ADC, all jumpers are in the default configuration.

When I start the GUI first and connect the EVAL-board afterwards, then the GUI will not recognise the board.

When I conect the board first and start then the GUI software, I receive the message "Unable to Identify device = ADS112U04" and after a few seconds: " Hardware Connected. Ready..."

But I dont see any registers, even if I click Refresh.

Windows 7 64-Bit System

Installed software:      - deltasigmaevalgui

- ads112u04evm-dvcpkg

In the device manager I see the following USB-Driver:  Tiva Ware Bulk Devices - Generic Bulk Device

I installed the software on two different Win 10 PC, with and without Admin rights when I run the setup.

This solution doesnt help for my problem: http://e2e.ti.com/support/data-converters/f/73/t/676621?jktype=e2e

Picture from device manager:

GUI:

  • Hi user5176873,

    It appears that the driver is loading and that the EVM is being recognized, but not as an ADS112U04.  Verify that the EVM is actually an ADS112U04 and not the 24-bit variant the ADS122U04.  It is very easy to mistake the 2 EVMs as the part number is so similar.  If you do have the ADS122U04EVM, then you will need to download and install the proper device package for this EVM.

    To see how the EVM is actually responding, you can select the checkbox in the General Options settings in the section Console Tab Enable (see Figure 6 on page 12 of the Delta-Sigma ADC EvaluaTIon Software User Manual).  If you then go to the Console tab in the GUI you should see the ID response coming from the EVM.  Let me know what the ID response is and we can further diagnose what is happening if you are still having issues.

    Best regards,

    Bob B

  • Hello Bob

    Thank you very much for the fast reply.

    I have the ADS112U04, the mark on the chip is:

    XDS112U 77KG4 CEFR

    and the EVAL board is marked as ADS112U04EVM-002

    The console output is the following:

    Sending USB>> ID

    ADS112U04 Nov/16/2017/18:20:09

    Best regards

    Cyrill

  • Hi Cyrill,

    The response is showing us that the driver has loaded properly and the EVM is indeed the ADS112U04.  As the GUI cannot find the files for the ADS112U04, it is possible that the device package installation is in a different directory than what the GUI is expecting.  This can happen if an admin user different from yourself installs the software.  The GUI is looking for the device package files under the user environment for the current user in the 'Documents' folder.  Search for a folder in 'Documents\DSEvalSW' to see if it exists.  If it does not, then you need to either reinstall the device package to the current user, or you need to copy the files from the user folder from the user that installed the device package.  

    Best regards,

    Bob B

  • Hi Bob

    I recognised that I installed the wrong packege! It was the ADS122U04!

    I installed the correct package ADS112U04 and now it works, I see all registers.

    Thank you very much for the help and sorry that I didn't recognise this stupid mistake.

    Best regards

    Cyrill

  • Hi Cyrill,

    I'm glad to hear you were able to figure it out.  As I said early on in the thread it is easy to confuse the parts as the numbers are so similar.  I 'm glad the solution was an easy one.  Feel free to post again with any questions.

    Best regards,

    Bob B