This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

ADS8881: EVM software 'Device Communication Error'

Part Number: ADS8881

I have been unable to connect to my ADS8881EVMV2-PDK from the ADS8881 EVM software.
It appears to me that the board driver is OK - please see Device Manager image below.
The LED D2 is normally flashing rapidly. When I start the ADS8881 EVM software, it momentarily stops flashing rapidly a couple of times, then shows the 'Device Communication Error' from the image below, and continues flashing rapidly.

I have measured the supply voltage at the EEPROM IC, and it is 3V3 as expected.

I see a couple of bursts of activity on the SCL and SDA pins of the EEPROM IC while the program attempts to start.

I am running WIN10 Pro on the PC I have installed the EVM software on.

Any suggestions? Could it be a faulty ADC EVM board, or some other explanation ?

I don't have any other ADC EVM boards on hand to try with the PHI-EVM-Controller.

  • Hi David,

    It is always possible you have faulty hardware, but these boards are tested during manufacturing to ensure everything works correctly to reduce the chances of this.

    After plugging the PHI into the EVM, did you install the two screws?  Depending on the tolerance of the mating connectors between the two boards, I have seen some cases where there is not a good connection without using the screws, and will get a similar error message.

    Are you plugging the USB cable directly into your PC, or through an un-powered hub?  The EVM requires quite a bit of current during startup, and if the USB current is limited, it will cause a brownout and similar connection error.  Directly plugging the EVM into an available USB port usually works, or using an external powered hub.

    Keith Nicholas
    Precision ADC Applications

  • Hi Keith,

    Thanks for your suggestions.
    I have installed the screws - but to be sure, I unplugged and re-plugged the connectors, then tightened the screws again - but nothing changed.
    I can see activity at the SCL and SDA pins of the EEPROM, so I think the connection is OK at least to the EEPROM.

    I plugged the cable directly to a USB port on the PC, and also tried it in another USB port on the same PC just to make sure. I also tried with another USB cable in case the cable with the EVM had a fault.

    I also tried installing the software on another PC (this time it was Win7 Pro), but the result was the same.

    I'm not sure what to try next?



  • Hello David,

    It appears that the EVM EEPROM data is either incorrect or corrupted.

    This EVM uses the same hardware as the REF6025EVM.  Although I have not seen this before, it is possible the EVM you have is configured as the REF6xxxEVM.

    Try downloading the REF6xxxEVM GUI software and see if that version works with your hardware.



  • Hi Keith,

    Thanks for your suggestion - you are right. It worked correctly using the REF6XXXEVM GUI.

    Is there an easy solution to re-program the EEPROM, or should I contact my supplier and ask for a replacement ?



  • Hi Dave,

    We do not have any customer tools to change the EEPROM settings.  I suggest you look into a replacement.


  • Thanks Keith,

    I'll follow up with the supplier who I purchased the EVM from.

    Best Regards,