This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

ADS1282EVM-PDK: ADCPRo DSP Not ready..Retrying >> fail (no USBStyx)

Part Number: ADS1282EVM-PDK
Other Parts Discussed in Thread: ADCPRO, ADS1282

I am trying to load ADCPro with the Eval board and a ADS1282EVM.

I have loaded the files very specifically how the install guide says, and I always get to the same point, no matter what I try differently.

Install ADCPRO-installer.exe and then ADS1282EVM-PDK-SW-installer.exe

Plug in my USB port and the NI-VISA driver loads.

With ADCPro and choosing the EVM for ADS1282, then ADCPRo says USB connection established, downloading firmware, download successful and then DSP Not Ready retrying etc till it times out.

I am in Windows 7

I have looked in Device manager and find the NI-VISA > MMB0 (NI-VISA) device but not USBStyx,and the following link doesnot have USBStyx driver.

"C:\Program Files (x86)\ADCPro\drivers"

Then ADCPro cannot work successfully. It shows"The firmware load has failed due to a timeout condition.Please reset...." But reset doesnot work!

So, what now?



  • Hi Evelyn,

    Welcome to the TI E2E Forums!

    After installing the ADS1282EVM-PDK-SW package from, you should see see the following files in the drivers/ folder:

    You'll need to run the mmb0_driver_install MSI file corresponding to your version of Windows (x64 for 64-bit OS).

    NOTE: If they are not showing up there then there might be a Windows permissions issue preventing them from copying to this location. In this case, then try running the ADS1282EVM-PDK-SW installer again and looking in your %TEMP%/ADS1282/ folder to find them.

    After installing this driver, try closing and re-opening ADCPRO, and make sure to provide the required +/-10V supplies to the MMB0. Without these supplies the ADS1282EVM will not connect.


  • Hi,Chris

    I have already installed mmb0_driver_install ,the evm with the wall supply,+/-10v and 5v additional supplies,but dsp not ready yet,

    so what to do next?



  • Hi Evelyn,

    Next, I would double check the jumper settings on the ADS1282EVM and the MMB0. Refer to Figure 4 and Figure 8 in the EVM User's Guide for required jumper settings.

    Then, I would recommend opening Windows Device Manager and trying to connect to the EVM again. Watch Device Manager to see after MMB0 disconnects if it re-enumerates as a USBStyx device, or if it re-enumerates as an "unknown device" (the icon will have a small warning symbol).

    If you see the unknown device, then I would try manually updating the driver for this device. Right-click on the unknown device and select "Update driver". Follow the windows prompts but do not have Windows try to automatically search for a driver (You can reference for addition instructions). Once you get to the menu with the "Have Disk" button, click this button and then browse for the usbstyx.inf file located at C:\Program Files (x86)\ADCPro\drivers\usbstyx\usbstyx.inf.

  • Hi Chris,

    After trying to connect to the EVM,MMB0 disconnected and i cannot see neither USBStyx device nor an "unknown device".

    So what to do?



  • Hi Evelyn,

    Would it be possible to share a picture of the ADS1282EVM setup?

    Also,do you have another PC you could try to use? Occasionally, we've seen issues on particular PCs that we've haven't been able to resolve, so trying the EVM on the another PC would be helpful to help me determine if this is a PC issue or possibly an issue with the ADS1282EVM.

  • Hi Chris,

    HELP!!!A little urgent!

    What is the picture of the ADS1282EVM setup,like the picture below?

    Also,i have tried to use another PC ,but it doesnot work either.

    The error is added below.

    I have seen the user's guide again,and before figure 13 ,it is the same.

    So what todo?



  • Hi Evelyn,

    Thanks for the image! The jumpers on the ASD1282EVM look good, but I didn't see the +/- 10V connections (or the +/- 5V connections).

    Here is where you would need to connect each of the supplies...

    NOTE: The -5V supply is optional if you don't plan to use the ADS1282 with bipolar analog supplies.

    • For the +5V supply, you'll want to connect this to the "+5VA" terminal, instead of the "+5VD" terminal as shown in your image. ALTERNATIVELY, you can use the wall supply but you would need to install jumper J12. NOTE: If you do use the wall supply, then do not connect anything to "+5VA"! Jumper J13B should be installed so that the 5V supply is provided to the ADS1282EVM daughter card.

    • The +10V supply should connect to "+VA" and the -10V supply should connect to "-VA". NOTE: Jumper J13A should NOT be installed or else it will short the +10V supply to the +5V supply!

    • ALL the supplies connected to J14 should share a common ground connection to the "GND" terminal.

    Try those connections and let me know if you're able to connect to the EVM then. If you still have issues, then likely the EVM is damaged or faulty and you would need to create a New case in our "Customer support center" to request a replacement EVM. However, I hope with the above clarifications that you're able to get the EVM to work.

  • Hi Chris,

    After changing my dsp,like the picture below,i have tried to install the mmb0 driver again.

    Also,after running ADCPro again,MMB0 disconnected and i cannot see neither USBStyx device nor an "unknown device" in device manager.And dsp not ready yet.

    So, does it mean there are some problems in my evm?

  • Hi Evelyn,

    The +/-10V supply also needs a ground connection to the MMB0 PCB. Therefore, you should have at least three (maybe even four) wires connected to the J14 header on the MMB0.

    The +10V supply should be connected between +VA and GND, and the -10V supply should be connected between -VA and GND. Without the common ground potential between these supplies the EVM won't work.

  • Hi Chris,

    Thanks for solving the problem for me.

    And i wanna to begin writing the code of ADS1282's data acquisition,so how can i download the code into EVM through ADCPro?Or i need to use Keil?



  • Hi Evelyn,

    I responded to this question on the other E2E thread:

    If you could provide some additional clarification about what it is you would like to do, it would help me answer your question. Thanks!