Due to the U.S. Thanksgiving holiday, please expect delayed responses during the week of 11/22.

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

DAC8811EVM-PDK: DXP Run Error

Part Number: DAC8811EVM-PDK
Other Parts Discussed in Thread: DXP, DAC8811

I get the following error message when I plug in the DAC8811EVM-PDK board into the USB port.  How do I correct this?

  • Hi,

    Which operating system are you using? Is it Windows 10 ?

    If it is windows 10, we have limited support for DXP. This software was released for windows XP and 7.

    Really the approach has been more oriented towards deploying new devices on new platforms, and as those platforms prove their maturity look into migrating popular legacy devices to the new platform as we see appropriate. If you want to go into further details concerning exactly which device you are looking to evaluate, we may have more modern similar devices on more modern evaluation platforms we could recommend. Or, we could look to support you in other ways if we are not able to resolve the issues you have with DXP right now.

    Regards,

    AK

  • Hi AK,

    It is a Windows 10 machine.  I just purchased this to evaluate the DAC8811.  Why is this kit being promoted if it is no longer being supported?  Is there a different platform that this can be exchanged for?  Has no one else come across this problem and solved it for Windows 10?  Please let me know what I can do to resolve this.

    Thanks,

    Dexter

  • Hi Dexter,

    Can you verify if the device is recognized in the device manager? The primary limitation for the DXP software (and the MMB0 controller) is that windows 10 requires that the driver be "digitally signed".  Unfortunately that is impossible with the MMB0.  There is a work around, but it is a bit... lame.  You can disable the driver requirement in Windows 10, and then restart your PC.  For that session the driver is usable, but you will have to repeat the steps once you power cycle the PC again. These steps are detailed here.

    Please let me know if the driver is detected and if these steps work for you.

    Thanks,

    Paul

  • Hi Paul,

    The driver is loaded as shown in the device manager, but I still get the same error message.  

    Thanks, Dexter

  • Hi Dexter,

    If you would, you could try a few more things:

    1. Can you install the NI-VISA library 14.0.1?

    I have seen that make a difference.

    2. Please launch DXP as an administrator as well.  

    Note you will still need to do the reboot trick to ensure the driver is loaded.

    Thanks,

    Paul