This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

ADS1262EVM-PDK: cannot connect to ADCPro

Part Number: ADS1262EVM-PDK

I received a new EVM today and tried to connect to ADCPro. on my Windows 10 laptop.  (I've successfully done this with this machine before)     I received a message "Error loading front panel" with this in Current Plugin Errors.txt:

VIs in ADS126XEVMPanel Bad VI
ads126Xevm.lvlib:EEPROM Check ID (ADS126XEVM).vi Bad VI
ads126Xevm.lvlib:EEPROM Read (builddate).vi Bad VI Bad VI Bad VI Bad VI

I thought the problem might be the firmware, so I read it using the I2C bus  on J1.  Everything is 1's until the last block, which contains this:

<p">127 bytearray(b'ADS1262EVM\x00\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff6580279-A\x00\xff\xff\xff\xff\xff\xff6580279-A\x00\xff\xff\xff\xff\xff\xff6580279-A\x00\xff\xff\xff\xff\xff\xff20200820\x00\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff\xff')

Here's the Python code to read the EEPROM using the Adafruit Blinka I2C library::

import time
import board
import busio

i2c = busio.I2C(board.SCL, board.SDA)
result = bytearray(256)
i2c.writeto(0x50, bytes([0x00]), stop = True)
page = 0
while page <= 127:
    i2c.readfrom_into(0x50, result)
    print(page, result)
    page = page + 1

  • Hi Patrick,

    Using ADCPro can be a bit finicky when using Win10 as it is old software and designed for Win7.  Many people can get ADCPro to work with Win10 (me included) with some effort.  However you might get one plugin to work while another will have issues.  A lot of this has to do with the drivers.

    You said you got this to work previously.  Which plugin/EVM combination did you use and was it the same PC ( I assume that it is)?

    You should be able to load the plugin, which where there seems to be an issue from the error log.  Have you tried downloading the plugin again and reinstalling the plugin?  It seems like maybe something may have gotten corrupted within the installation.  Also, you must have administrator rights when installing the GUI/plugin.  

    It appears that the EEPROM has been programmed correctly which is sometimes an issue.  But as the error text is showing bad VIs, this is something more related to the GUI plugin itself.  The firmware is actually downloaded to the MMB0 in the startup process of the plugin.  If the plugin doesn't load the firmware won't load either.

    Best regards,

    Bob B