This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

ADS4125IRGZT

Prodigy 100 points

Replies: 1

Views: 46

Hello, our company has a mass-produced product using ADS4125 IRGZT;The instrument is a hand-held measuring instrument.

This is how the instrument works:The signal of the sensor is conditioned, converted by ADS 4125, and then transmitted to the tablet computer through WiFi to display the sampling waveform.Actual ADS 425 uses 50M sampling rate.

Now there are some problems, please help me to analyze the causes of the failure.Specific failures are:The waveform output by AD sampling is displayed on the tablet computer, and the zero of the waveform drifts.The amplitude of the sampled waveform displayed is much smaller than that of the analog signal input to ADS4125.

The actual input analog signal is 800 MV vpp, and after AD sampling, the waveform amplitude displayed is only 20 mV vpp.Probably four of the 10 instruments have had these two problems.

This problem has lasted for a long time. We haven't found out the reason. Please help me to analyze it.Is there a problem with the hardware schematic of ADS4125 or with the software driver, or with PCB welding?

 

1 Reply

  • Guru 51170 points

    User,

    Is this a problem with a custom board you built that has the ADS4125 or are you using the TI ADS4125EVM? I cannot tell by your description. In either case, I would check the following:

    1. Voltages to the ADC are correct.

    2. The registers are programmed properly if using the serial SPI mode. Read back the registers and makes sure they are set to the correct value.  If using parallel SPI mode, verify control pins are set to the proper voltage.

    3. The ADC is getting a valid reset pulse, either hardware or software, after power and clock is present.

    4. Probe the analog input at the pins of the ADC to make sure this input is at the correct amplitude.

    5. Make sure all digital outputs are toggling. Place the part in ramp test pattern mode to verify this.

    Regards,

    Jim

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.