ADS1299EEGFE-PDK: Software response is too slow

Genius 10585 points

Replies: 7

Views: 120

Part Number: ADS1299EEGFE-PDK

Hello Guys,

Good day.

Our customer is encountering an issue where the response of the software is too slowly to use. He is using a wall-power source for this. he then change to a battery source since according to the user guide using a battery source minimizes the amount of noise pickup seen at the digitized output of the ADS1299. 

However, upon changing to the battery source and changing OS to win7, he cannot use the ADS1299EEGFE-PDK at all.

Any thoughts on this?

Thanks in advance!

Art

7 Replies

  • Expert 3270 points

    Hi Art,

    It will be helpful if the customer can provide more details as to what the issue is when they are using the battery source for the EVM. Are they able to load the EVM firmware from the PC GUI and connected to the EVM? 

    Thanks.

    -TC 

  • In reply to TCT:

    Hello TC,

    Additional information from the customer below.

    At first, he connected the EVM to the battery source and PC, and then the light and Nixie tube on the EVM came on. On the PC GUI, the top 'Processing' bar slowly increased and need more than 10 mins to 100%, at the same time of bar increasing, there was a green note of 'reading register' on the top-left. In that increasing time, clicking GUI was almost unresponsive. After the bar arriving to 100%, clicking also almost unresponsive. And when he clicked on "Acquire", an error code as '6004' appeared.

    Let me know for any additional information needed.

    Art

  • Expert 3270 points

    In reply to Art Mecina:

    Hi Art,

    Thanks for the additional information. Is the customer connected the EVM to the battery source described in Section 9.4 of the user's guide? I'm not sure what the error code '6004' means. I'll try to duplicate the setting and let you know the results. 

    Thanks.

    -TC

  • In reply to TCT:

    Thanks TC!

    I'll let you know as soon as we got confirmation from the customer regarding his set-up.

    We'll be waiting for the result of your replication.

    Best regards,

    Art

  • Expert 3270 points

    In reply to Art Mecina:

    Hi Art,

    Sorry, I forgot to ask if they are able to get the EVM working with the wall-power source using the same existing setup.

    Thanks.

    -TC

  • In reply to TCT:

    Hi TC,

    Yes they able to get the EVM working with the wall-power source using the same existing setup. However the software response is too slow to use.

    Art

  • Expert 3270 points

    In reply to Art Mecina:

    Hi Art,

    Thanks. Is it correct that the software response is slow even with the wall-power source? 

    Can you ask them to check and make sure all the jumper settings are in the proper positions? I have seen this issue with the software not responding when there is no clock to the device or no DRDY pulse to the MMB0 board. I have attached some prior discussions on this topic below for your reference. 

    https://e2e.ti.com/support/data-converters/f/73/t/697045

    Thanks.

    -TC