• Resolved

could not open source file "csl.h"

Hi everyone

 i am getting a - could not open source file "csl.h"  error when i am compiling the my code.

I used the code before on the code composer 3.1 and it worked but now i am using ti on the ccsv4  but its giving me the csl.h include error when comiling.

 

Any body have an idea on this

  • Genius 4530 points

    Hi habeeb,

    Have you referred this?

    http://processors.wiki.ti.com/index.php/Importing_CCSv3_Projects_into_CCSv4

    Have you updated your include path with the location of your CSL as stated in this wiki?

    Regards,

    Sid

  • In reply to Sid:

    I have tried that but in main .c  it still says "could not open source file "csl.h"

  • In reply to habeeb siddique37664:

    CCSv4 does not ship with CSL. You can use the same CSL version that comes with your CCSv3.1 install. Just add the path to the CSL header files to your include build options. You can do the same for the CSl library itself in the linker options.

    Thanks

    ki

    -----------------------------------

    Did you read the CCS Forum Guidelines & FAQ? If not, PLEASE read it. If you haven't read it in awhile, please read it again to see if any updates were made.

    Having CCS problems? Check out the CCS Troubleshooting Guide

    Looking for CCS Training? Check out the CCS Training Site

    Curious about the status of a bug and know the tracking ID? Track it via the public bug tracking portal

  • In reply to Ki-Soo Lee:

    Thank you very much. I do not have the  code composer 3.1 with me . i had uninstalled the code composer3.1 and then installed  code composer v4.

    Is there any source from which the csl header files could be downloaded.

     

    I am also not able to access the include build options . If you please direct me on that as well. Thank you very much

  • In reply to habeeb siddique37664:

    habeeb siddique
    Is there any source from which the csl header files could be downloaded.

    http://processors.wiki.ti.com/index.php/CSL

    habeeb siddique
    I am also not able to access the include build options

    Right click on your project and select "Build Properties" in the context menu. Then select "C/C++ Build" in the left panel. In the right panel under "Tool Settings" tab, you can get to the Compiler and Linker options. The include build options are under "Include Options"

    ki

    -----------------------------------

    Did you read the CCS Forum Guidelines & FAQ? If not, PLEASE read it. If you haven't read it in awhile, please read it again to see if any updates were made.

    Having CCS problems? Check out the CCS Troubleshooting Guide

    Looking for CCS Training? Check out the CCS Training Site

    Curious about the status of a bug and know the tracking ID? Track it via the public bug tracking portal

  • In reply to Ki-Soo Lee:

    I have found  the "6000 Linker" under the "Tool Settings" tab, but underneath  "6000 Linker" i have not been able to find the "Include Options". I found   "File Search Path" option under   "6000 Linker" option.

    This is the action taken.

    1. I clicked on the   "File Search Path" option under   "6000 Linker" option.
    2. I clicked on the " add note " icon on the " Include library file or command file as input " box.
    3.  a new box with title " Add file path " came up . I put in " c:\Program Files\C6xCSL\include" and pressed ok .
    4. press debug

     

    the result:

    The " could not open source file 'csl.h' " error still occurs.

  • Genius 4530 points

    In reply to habeeb siddique37664:

    I dont remember exactly, but I once had a similar problem, when porting project from CCS3.3 to CCS4.

    It turned out that since CCSv4 is based on eclipse, the path of the project file should have exactly opposite slashes in the path as compared to CCS3.3. So a backslash (\) in the path needs to be replaced with a forward slash (\). See if that works.

    Regards,

    Sid

  • In reply to Sid:

    i have replaced the " \ " back slash by "/ " front slash but the " could not open source file 'csl.h' " error still persists.

  • Genius 4530 points

    In reply to habeeb siddique37664:

    You can try out one more thing.

    Copy the csl.h file from the present location into your project folder. Then explicitly define the path in your project file, as in

    #include "C:\project_name\...\csl.h"

    and see if it recognises the path/ takes up the correct file.

    Also, try to ensure that your path doesnt contain spaces as it is doing right now. Sometime some eclipse based softwares dont recognise files containing spaces in their path. (eg. here Program files). Try to use undersocre isntead.

    Regards,

    Sid

     

  • In reply to Sid:

     i changed the include path explicitly in the files by writing the whole path name and also by explicitly adding the csl.h file to the project files . it still presents the same error  " could not source file 'csl.h'  "

    the error " could not source file 'csl.h'  "means it cannot open the csl.h header file. do you think the issue is not with file being added or not but being not able to open the file.

    can there be any restrictions on file access???