This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

DLPLCRC410EVM: Where can I find the D4100Explorer-2.0-windows-installer.exe file mentioned in the manual?

Part Number: DLPLCRC410EVM
Other Parts Discussed in Thread: DLPLCR70EVM


I plan to start testing the device (D4100 kit) with the TI software first, however, I cannot seem to find the file (D4100Explorer-2.0-windows-installer.exe) mentioned in the manual on the website. Does anyone know where can I find it, or whether I should just download one of the GUI files? In addition, as I have DLPLCR70EVM, which GUI file should I download? Thank you very much in advance for your help!

  • Hello Ke,

    Welcome to the DLP section of the TI E2E forums.

    You can find the GUI on this page:  -- It is the fourth item on the list


  • Hi,
    I have tried downloaded this file, however, when I try to run the DDC4100.exe file, this error always shows up. I have checked with live chat support team, and they also have the same issue on their end.

  • Hello Ke,

    What version of Windows are you running?  Please open a command prompt and type "winver".

    Please download the latest VCRedist from Microsoft and install it.  Not the 64 bit version, but the 32 or X86 version.  The version needs to match the program that you are trying to run.

    After installing and rebooting, try re-running the installer.


  • Hi, 

    I have downloaded the latest VCRedist x86 version, rebooted and reran the installer, but it still reported the same error. Is there any other solution you would suggest? Thank you!

  • Hello again Ke,

    Please let me know the version of Win 10 you are running.

    Also you can try manually registering DDC4100.ocx.

    • The 64-bit version is %systemroot%\System32\regsvr32.exe.
    • The 32-bit version is %systemroot%\SysWoW64\regsvr32.exe.

    You will need to find the ocx file.  In Win 10 64 bit systems it should be in %systemroot%\Windows\SysWOW64

    Try running the command with admin in a command window in the directory where the ocx file is.

    The command should be:

    %systemroot%\SysWoW64\regsvr32 <full path of the OCX>


  • Hi,

    I have the 2004 version of win10 running.

    For manually registering the .ocx file, we kept running into the following error, and rebooting and redownloading doesn't solve the problem. Do you have any suggestions of what we should do? Thank you!

  • Hello again Ke,

    This is usually what you get if you don't provide a module (dll or ocx) file name after the command.

    So for example on my system from an elevated command window the command line would be 

    C:\Windows\SysWoW64\regsvr32 C:\Windows\SysWoW64\DDC4100.ocx

    In the command window you could try changing to the Windows\SysWoW64 directory [i.e. cd C:\Windows\SysWoW64\]

    Then assuming the DDC4100.ocx file (and its matching *.tlb file) are in the SysWoW64 directory the command would be:

    regsvr32 DDC4100.ocx

    If that does not work, I am not sure what to try beyond completely uninstalling the software, rebooting, and attempting to re-install.


  • Hi Fizix,

    Thank you so much again for your kind help, and we are very sorry that we kept coming back with more questions.
    In fact, after installing the old version GUI and ran the .exe file mentioned in the manual, our initial error went away and now we can open the GUI. But the device seems to fail to be recognized by the GUI, and the driver reports the following error, do you have any suggestions of what we should do? Thank you.

  • The GUI actually worked and this is how we got it working:

    1. Download both versions of the GUI from the TI website;

    2. Open the old one first and run its .exe as the manual mentions;

    3. Open the new one and go into its GUI folder and open the DDC4100.exe file, which opens the GUI;

    4. If the DMD is not automatically connected, open the device manager and find the DMD being listed under "other devices";

    5. Double click the device, and let Windows automatically search and download the driver, and then the DMD should be connected.

    Please correct me for anything we did wrong, and any comments and suggestions will be strongly appreciated!

  • Hello Ke,

    Although I am not sure why it worked, it is hard to argue with success.  

    We are also sorry for the issues you encountered.