The TI E2E™ design support forums will undergo maintenance from Sept. 28 to Oct. 2. If you need design support during this time, contact your TI representative or open a new support request with our customer support center.

DLP3010EVM-LC: DLP3010

Part Number: DLP3010EVM-LC
Other Parts Discussed in Thread: DLP3010, DLPC3478, DLP3010LC, DLP4710EVM-LC, DLP4710LC

Hello everyone,

I am testing my DLP3010 projector refer to DLP3010EVM-LC.

But I found the DLP3010 projector will occur system halted when sending IIC command without stopping for several hours or longer.

At this time the projector is no response, meanwhile the SCL signal of IIC is locked low always. 

So once the projector halted, I must reboot the projector by turning off the projector on signal.

System halted and reboot is unacceptable in my using.

Thany you for any help.

Regards,

Yang

  • Hello User,

    Thank you for your interest in DLP technology.

    What FW version and GUI version are you using? If you are not using our GUI what are you using to communicate with the EVM?

    To clarify, are you saying the EVM will operate for a couple hours then this behavior shows and it will not take commands?

    Regards,

    John

  • Hello John,

    Thanks for your reply.

    The FW version of my DLP3010 projector is 8.0.0 and the GUI version is 2.2.0.6.

    I only use the GUI config the pattrern sequence with internal pattern mode, then use stm32 MCU send run once command by IIC interface.

    The MCU send a run once command  every 200ms.

    Normally the DLP3010 project display the patten sequence followed the run once command, but after several hours or more than one day the projector will not take IIC commands and not display pattern. The IIC command is 36 9E 00 00 in HEX.

    Above case also happened if the IIC bus send a wrong command, such as 36 45 00 00 in HEX. Once IIC bus send the wrong command, the DLP3010 projector will stop working immediately. 

    I am confused why a wrong IIC command could stop the DLP3010 peojector.

    Regards

    Yang

  • Hello User,

    Please allow us some time to look into this since the nature of the behavior seems time dependent. This may take more time.

    Thank you for your patience.

    Regards,

    John

  • Hello User,

    Can you send a screen grab of the GUI error message code when the EVM fails? This can be from the even viewer or the Advanced mode.

    Can you also make a list of the amount of hours it took for the EVM to not take commands?

    Regards,

    John

  • Hello John,

    The screen grab of the GUI error message is as below.

     

    This is I send 36 45 00 00 in HEX by IIC to my DLP3010 board, then get the GUI status failed.

    I have measured the IIC signal using oscilloscope as below picture.

    This is the normal wave form, the yellow line is the SCL of IIC and the green is the SDA of IIC.

    But when I send 36 45 00 00 in HEX, the SCL of IIC will be pulled down and keep low level always.

    So I must reboot my DLPC3478 board by PROJ_ON switch or power down the board.

    I am sorry that I can not list the time from power on to the EVM to not take commands.

    Sometime the time is several hours, and also the time is maybe more than one day.

    Have you a DLP3010EVM-LC board which could reproduce my case by send 36 45 00 00 in HEX?

    Thank you for you help.

    Regards,

    Yang

  • Hello Yang,

    Thank you for sending these scope plots.

    Please allow us until next week to try to recreate this issue on our system.

    Regards,

    Austin

  • Hello Yang,

    We noted this behavior. There is not currently a fix for it. Thank you for bringing it to our attention. We will have to work for a solution in the future.

    Thank you for your patience.

    Regards,

    John

  • Hello John,

    Thank for you followed this trouble.

    It is very usefull that you have observed this behavior.

    But I also want to confirm how you reproduce this behavior, by sending normal 36 9E 00 00 in HEX continuely for a long time or sending a wrong 36 45 00 00 in HEX? Because I am not sure whether they are same problem.

    Thanks for your help.

    Regards,

    Yang

  • Xu,

    Thanks for additional information. We are suspecting this to be a known issue that was fixed recently and is not yet released on ti.com yet. We will get back to you with more updates soon.

    Regards,

    Mayank

  • Xu,

    Can you please check if you can reproduce the same issue on the EVM?

    Also, as indicated earlier, DLPC3478 can be used with DLP3010LC only from firmware version v8.x.x onwards.

    Regards,

    Mayank

  • Hi Mayank,

    My DLP3010LC-EVM have broken and does not work.

    So whether TI can reproduce the case on a DLP3010LC-EVM.

    I test DLP3010 and DLP3010LC. They both could reproduce the same issue on my board with BLUE_LED_ONLY firmware based on version 8.0.0.

    Because My board only assemble one bule LED.

    Is there any issue for signle LED design?

    Thank you for support.

    Regards,

    Yang

  • Hello Xu,

    Can you give more details on the EVM being broken? Is the HOST_IRQ signal going low when you place the switch into the on position?

    I see that you asked for a blue LED only FW already but for a 4710EVM-LC unit. Who did you speak with to get blue led only FW for the 3010EVM-LC?

    Best,

    John

  • Hello John,

    My DLP3010LC-EVM have been broken too long times and the display board has been missed.

    I am asking for a blue LED only FM for DLP4710EVM-LC, because we are develop DLP4710LC projector  for a blue LED only.

    And my DLP3010LC board is also a blue LED only projector.

    I am not sure who has provided the DLP3010EVM-LC blue LED only FM, because I don't know who my previous workmate contact to get blue LED only for the 3010EVM-LC with v8.0.0 about one or two years ago.

    Now is there any doubtful issue point, whether my board or firmware?

    Regards,

    Yang

  • Hello Yang,

    Do you have the original FW image file itself? Can you try and reflash the EVM with the 3010EVM-LC FW image in your possession?

    It will be better to flash the EVM while in standby mode.

    Regards,

    John

  • Hello John

    I can download the original FM with V8.0.1 and I will reflash it in my board in standby mode.

    After, I will test the IIC issue on my board.

    Thanks for support.

    Regards,

    Yang

  • Hi Yang,

    Thank you for doing that. 

    Please let us know if you have questions.

    Regards,

    Lori