This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

DLPLIGHTCRAFTER: Error with tida-00361 and MSP430 Firmware version


Helo, we are trying to follow the tida-00361 design reference for 3D scanning, but we're having some issues with the lightcrafter.

We have followed the instructions of tida-00361 till the camera calibration, where says that a white pattern will be projected, and we have no projection since the application started.


The camera identify all the 20 patterns with success (option 4).

When the option 5 is selected we got an error "LCR3000_SEND_COMMAND_FAILED".

We thought that should be some issues with the Lightcrafter, so we've downloaded the "DLP LightCrafter Firmware and Software Bundle - Windows" (Version 3).

When the GUI connect with the board we got an error about the MSP430 firmware version.

So we've tried to update the firmware, there is a txt file "lcr_msp430_v3.txt" inside the DLP3000-C300REF-MSP430-v3.0 folder, it looks like an hex file in ascii, but the return is "command Success" but the firmware version remains 0.0. 

  • Hi Armando,

    Thanks for your question and welcome to the DLP Forums. Did you unplug the Lightcrafter and plug it back in after the update? Does it still show v0.0?

  • Hello Paul, thanks for your reply.
    Yes I did those steps because the power button doesn't work after the process, but nothing happens. I think that maybe there is some problem with the MSP430 or with the board itself because the other firmware (DM365 and FPGA) are updated to the last version by default. Just the MSP430 have this problem, and the version "v0.0" is a little weird, it doesn't make sense, should be at least v0.1.
  • Hi Armando,

    Sorry for the delayed reply. You are right, it is strange that the version number didn't update and it doesn't appear that the update worked even if it says "success." I haven't seen this particular error happen before

    Have you tried the procedure more than one to see if it works again?

    Are there any modifications to your Lightcrafter EVM?

    The next thing that I would try would be to reload the other parts of your system's software to make sure that nothing at all is corrupted. That would mean following the steps in 2.13.2 in the user's guide: 

  • Hi Paul, thanks for you reply.

    Yes, I've tried more than once.

    No, there are no modifications on the Lightcrafter EVM.

    I have tried to update de firmware and even boot directly from the SD card, but the problem remains the same.  

    Any other guess? I still think that should be some physical problem with the board, maybe with the MSP430 itself or the communication interface.

    I don't know where the MSP430 are needed on the Lightcrafter EVM, but here is a list of what is working:

    - I can connect through the USB cable (NDIS);

    - The module project the splash screens and the test patterns, some vertical colored bars;

    - The selection of the test pattern on the GUI is working;

    - I can upload a BMP image through the GUI and project;

    - I can change de IP address;

    - I can boot either from the SD card or the NAND;

  • Hi Armando,

    Can you test a pattern sequence using the GUI? The MPS430 is used to boot the system, so the fact that it boots means that it appears to be working.

    When using the machine vision reference design you still get the "Command Failed" error?

    You might want to reinstall the GUI just to make sure that it isn't some error with it which is causing the MSP430 version to report as v0.0

    When I use the Lightcrafter Machine Vision reference, I usually confirm that the projector is connected to the computer by firing up the GUI. Once I know it's connected, I close the GUI and open the machine vision .exe.

  • Hello Paul,
    Yes, I can test the pattern sequence using the GUI.
    The "Command Failed" error remains the same, I've tried to reinstall the software but nothing changes.

    I'm following this procedure to test:
    1 - Power up the projector and wait for the colored bars pattern
    2 - Connect the USB cable to the PC
    3 - Wait for the windows get the correct IP address for the NDIS interface (ipconfig)
    4 - Open the GUI and connect to the device to verify if it's everything ok
    5 - Disconnect and close the GUI
    6 - Open the scanner application, when I open the application the projector stops the current projection.
    7 - Run the option 3 "Prepare system for calibration and scanning", everything looks fine here, even the connection with the projector.
    8 - Run the option 4 "Calibrate camera", here the instructions say that a solid white pattern will be projected, but it's not.
    9 - Do all the camera calibration steps (20 images), and receive a success status message.
    10 - Run the option 5 "Calibrate System", here I got de command failure message.

    About my computer, I'm running Windows 10 Pro (1703 build 15063.413).

    I really need to run this 3D scanner reference application to verify if the DLP is suitable for my project, but I think that maybe my evaluation module has some issue, reinforced by the MSP version on the GUI.
  • Hi Armando,

    Thank you for your detailed description of the steps you're taking.

    One thing I noticed is that is the system is not projecting patterns when it says it will. Normally we have that issue if the camera triggering is not setup correctly or is using the wrong connector. What type of camera are you using? Can you confirm that the pins you've selected for triggering are correct?

  • Hi Paul,
    Thanks for your reply.

    I'm using the Microsoft LifeCam Cinema as described in section 3.2 of the TIDA-00361 User Guide.
    There is no trigger cable, it seems to be required only with the Flea3 camera, wich is the next step in a few months, to test the Hybrid Three Phase Shift algorithm.
  • Okay. With the LifeCam, there are a couple things that you need to make sure are correct. The first is that your projector exposure and camera exposure are long enough. The second is that in the config_projector.txt folder, you'll have to change the trigger type:

    LCR3000_PARAMETERS_INPUT_TRIGGER_TYPE is the parameter you're looking for. You'll want to change its value to 1.


  • Hi Paul,

    Thanks for your reply.

    I've changed the input trigger parameter, but the errors remain the same.

    There is any way to debug this?

    Here is my /config/config_projector.txt file


    and my DLP_LightCrafter_3D_Scan_Application_Config.txt file

    #Camera type
    # 0 - Uses OpenCV camera interface
    # 1 - Native camera interface - PointGrey 
    CAMERA_TYPE					= 0
    # Algorithm type
    # 0 - GrayCode
    # 1 - Hybrid Three Phase Shift
    ALGORITHM_TYPE					= 0
    CONFIG_FILE_PROJECTOR				= config/config_projector.txt
    CONFIG_FILE_CAMERA				= config/config_camera.txt
    CONFIG_FILE_CALIBRATION_PROJECTOR		= config/calibration_projector.txt
    CONFIG_FILE_CALIBRATION_CAMERA			= config/calibration_camera.txt
    CONFIG_FILE_GEOMETRY				= config/geometry.txt
    CONFIG_FILE_STRUCTURED_LIGHT_1			= config/algorithm_vertical.txt
    CONFIG_FILE_STRUCTURED_LIGHT_2			= config/algorithm_horizontal.txt
    CALIBRATION_DATA_FILE_PROJECTOR			= calibration/data/projector.xml
    CALIBRATION_DATA_FILE_CAMERA			= calibration/data/camera.xml
    DIRECTORY_CAMERA_CALIBRATION_IMAGE_OUTPUT	= calibration/camera_images/
    DIRECTORY_SYSTEM_CALIBRATION_IMAGE_OUTPUT	= calibration/system_images/
    DIRECTORY_CALIBRATION_DATA			= calibration/data/
    DIRECTORY_SCAN_DATA_OUTPUT			= output/scan_data/
    DIRECTORY_SCAN_IMAGES_OUTPUT			= output/scan_images/
    OUTPUT_NAME_IMAGE_CAMERA_CALIBRATION		= camera_calibration_capture_
    OUTPUT_NAME_IMAGE_SYSTEM_CALIBRATION		= system_calibration_capture_
    OUTPUT_NAME_XYZ_POINTCLOUD			= _pointcloud

  • Armando,

    I noticed that you're running on Win10. We have not tested this platform for Win10 which may be causing issues. If you have a Win7 machine you can try this on, that would be a good first step.

    Second, I would make sure that you actually have pictures in the following folders:

    If there aren't pictures there, then there is an issue with the camera actually grabbing pictures.
  • Hi Paul, 

    I've tried on Windows 10, and there are images on the "camera_images". On the "system_images" there are no images, that make sense once the application cannot perform the system calibration step.

    On Windows 7 the GUI is working fine (getting the same msp firmware error), but the scanner application is not running, I got the following error:

  • Hi Armando,

    At this point I have to admit that I'm a little stumped. After reviewing what we've covered, I still believe that the issues you are having with getting images must relate to using the Microsoft LifeCam. With my Point Gray, I have no trouble at all.

    I'll need a little time, but I'll try using this design with the a LifeCam and post back.

  • Hi Armando,

    I am able to get the Lifecam and Lightcrafter system mostly working and I'm not seeing the error that you are. Before you select option 5 to do system calibration, are you selecting option 3 to prepare the system?

    Do you by chance have access to another Lightcrafter to try this on?

    I think at this point, the next best step is to try to reflash all of the firmware on the Lightcrafter via SD card. Hopefully this will reset everything and clear whatever corruption is happening and causing your MSP430 version to read as 0.0. You can find the directions in section 2.13 of the Lightcrafter's user guide:

  • Hi Paul,

    I don't have access to another Lightcrafter, this one was already too expensive (we have huge taxes for imported products here in Brazil) to evaluate the technology.

    I've already tried to reflash the firmware via SD card more than once, but nothing changes. I really think that should have some issue with the board, there is any way to replace the board?
  • Hi Armando,

    Unfortunately I don't know of any way to get you just a replacement board. As far as the SD card flashing procedure, have you tried a few different SD cards? I had to try a couple before finding one that worked. In the end, a 4GB SDHC card worked for me but if you are able to find a smaller (1GB or 2GB) non SDHC card will usually work the most reliably.

  • Hi Paul, I've already tried with some different SD cards, and the flashing procedure is completed with success, but the errors on the application remain the same.

    The last one that I've used is one 8GB Kingston SDHC.

  • Hi Armando,

    Can I ask where you originally bought your Lightcrafter from? It looks like there may be others with your same issue.

  • Hi Paul, I bought it from Mouser.
  • How long ago did you purchase it and has the MSP430 version always been 0.0?

  • I bought it on 05/22/2017 (invoice 44282436).
    Yes, the MSP430 Firmware has always been 0.0.
  • Hi Paul,

    I have contacted the Mouser Electronics support and they replaced the board, the new one is working perfectly as expected.

    Thanks for all.

  • That's great Armando. We've started looking at why you had a bad unit so thanks for bringing it to our attention.