This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • TI Thinks Resolved

DLPC350: Can't communicate with DLPC350 until HID devices are uninstalled.

Intellectual 425 points

Replies: 25

Views: 2579

Part Number: DLPC350

Hi,

We are using the DLP350 controller on a custom board.  It is communicating to the host PC via USB.

We have several of these systems. In most cases the USB communication operates fine, but on some systems your software (Lightcrafter 45000) and our custom software is unable to connect to the DMD until we uninstall all of the HID device drivers and restart the system.

This is proving a big problem for our operations.  Do you know what the solution is to this?

Regards,

Oliver.

  • Hello Oliver,

    Sorry to hear about this problem. In order to help could you please let us know what version of Windows is on your PC and what version of the GUI are you using?

    Thanks,
    Kyle
  • In reply to Kyle Rakos:

    Hi Kyle,

    We are running windows 10 and the light crafter version is v3.1.0 [Jun 1 2017 08:55:26].

    Thanks,
    Oliver.
  • In reply to Oliver Tedder:

    Hello Oliver,

    Thanks for the information. We will look into this and let you know if we have further questions. Expect a reply from a member of our team early next week.

    Thanks,
    Kyle
  • In reply to Oliver Tedder:

    Hi Oliver,

    This is a known issue on Windows 10 environments. We aim to fix this issue on the next version of the GUI which is in validation stage and will be released soon. I can inform you as soon as it is released.

    Thanks & Regards,
    Hirak.

  • In reply to Hirak Biswas:

    Thanks Hirak. However this problem also presents itself when using our custom software as well, that is it occurs independently of the GUI. Is this also going to be fixed?

    Thanks,
    Oliver.
  • In reply to Oliver Tedder:

    Hi Oliver,

    Kindly make sure you are on the latest PROM flashed on DLPC350. There were issues with HID enumeration on the previous GUI build. The new GUI does not present any USB HID issues till now on Windows 10.

    Thanks & Regards,
    Hirak.
  • In reply to Hirak Biswas:

    Hi Hirak,

    Are you talking about the firmware "DLPR350PROM_V3.1: CURRENT VERSION -- DLPC350 Configuration and Support Firmware", version 3.1 from here (www.ti.com/.../dlpr350) (the marked date is 14 Jun 2017).
    I believe we are already using this (with our custom images).

    Oliver.
  • In reply to Oliver Tedder:

    Hi Oliver,

    Similar USB communication issue was resolved in another thread e2e.ti.com/.../698715 . Kindly take a look, this provides a workaround for the USB issue.

    Thanks & Regards,
    Hirak.
  • In reply to Hirak Biswas:

    Thanks Hirak, but that thread seems to talk about a different problem.  We don't get any errors about data mismatch.  Also in our case the problem is not reproducible, sometimes it works and sometimes not.  When it fails, we have to go through the process of uninstalling all HID devices.

    Cheers,

    Oliver.

  • In reply to Oliver Tedder:

    Hi Oliver,

    Since you say that only some systems you observe the problem, are those particular systems have their HID drivers updated to the latest version?

    Regards,
    Hirak.

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.