This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • Resolved

DLP4710: How to update the flash memory images to load my own patterns

Prodigy 80 points

Replies: 4

Views: 388

Part Number: DLP4710

Dear Sir/Madam

I am using DLP4710-G2 (controller DLPC3439) and using the LightCrafter GUI V7.4 software. Now after connecting with USB cable, it has four patters in the flash memory. However I want to update the patterns to my own patters and do not know how to do this. Could you please provide me a step-by-step operation for this? 

I find "update flash image" in "Firmware" page, but it always has error when I try to do this. It requires the input firmware files (input image) but I do not know where I can obtain this input firmware file. (I tried to backup a firmware file firstly, but when I select this backup file it says "selected image does not match..it is meant for a DLPCDLCR2010EVM" but I did backup with the 4710EVM so I do not know what is wrong..)

I also find a similar question link https://e2e.ti.com/support/dlp/f/94/t/627098  but the files you provided in that link is not valid, maybe since it is an old question. So could you please provide me new files or the steps for my question? Thank you.

Best 

Chenliang Chang

  • Hi Chenliang,

    Please see the EVM GUI tool user guide to see the firmware update. Available at this location : 

    Please use the latest GUI Tool v7.4 with latest firmware v7.3.2 you will not face the mentioned error - "selected image does not match..it is meant for a DLPCDLCR2010EVM"

    Firmware and GUI is also available at the same location mentioned above. 

    Please let us know if you face any issue.

    Thanks,

    Navneet 

  • In reply to Navneet Singh:

    Hi Navneet

    Thanks for your reply. I still can not access this process. I just send you the screenshot images from my steps as follows: 

    my software version is shown as

    In "Firmware" page I click "Get started"

    Here I am not sure about my operation. For input image I load the 7.3.2 document downloaded from you website you send me before. For output image I just name a new document by myself. Is there anything wrong in this step?

    This page I did not change anything

     

    This step I loaded a color image of 1920X1080 resolution from my computer (lena19201080.jpg) to splash 1

     

    Finally when I click "finish" it has the error "File is not a valid image"

     

    So based on the above figures could you please tell me what is wrong? Thank you. 

     

    Best

    Chenliang

  • In reply to Chenliang Chang:

    Hi Chenliang,

    Assume your images are your steps -

    1. Check the version - Correct

    2. Get Started - Correct

    3. Input image is the released one from ti.com and output image is your new file - correct

    4.  user defined looks - please click on skip

    5. splash image - please see the size of the splash, try to get maximum 300KB for experiment. try 720p resolution first. (or use this attached image)

    6. Click finish - correct

    At this stage you can see the new firmware without any issue.

    or you can use the Advanced page to update the flash "Flash Image Update", but there you need to create one autoinit batchfile ( for details of autoinit batch file chaeck the GUI tool user guide)

    Thanks,

    Navneet

     

  • In reply to Navneet Singh:

    Hi Navneet

    Thanks for your reply. Now I can update the splash successfully following your instructions. I also find there is something wrong with my previous firmware file and I downloaded it again suing your provided link and now I can make it successfully. 

    Thanks a lot for your help.

    Best

    Chenliang  

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.