• TI Thinks Resolved

DLP2000: sh: 1: ic2set: not found

Expert 5495 points

Replies: 3

Views: 30

Part Number: DLP2000

Hello Team,

My Customer followed the e2e FAQ link below, up to the “./pattern_disp” part to display testing patterns, and their BBB had flashing of different colors on the projector with the message "sh: 1: ic2set: not found"

 https://e2e.ti.com/support/dlp/f/94/t/667207

Any help is highly appreciated.

Regards,

Renan

  • Renan,

    What does i2cdetect return? Are you seeing any devices on Bus #1?

    If you have a unique system configuration, perhaps your I2C interface is not on the default bus.

    Regards,

    Philippe Dollo

    --------------------------------------------------------------------------------------------------------

    If a post answers your question, please click the "Verify Answer" button.

    Have questions about DLP Pico Chipsets? Check out the DLP Pico Universal FAQ for quick answers: https://e2e.ti.com/support/dlp/f/94/t/946506 

  • In reply to Philippe Dollo:

    Hello Philippe,

    Good day and thank you for this response.

    I got a confirmation from my customer and they get the same error when they put in i2cdetect. They don't think they configured their system though because they don't really know how to do that. Speaking of which, they what to know what do you meant by "on bus #1"?

    Regards,

    Renan

  • In reply to Renan Santos Adriano:

    Hi Renan,

    It appears as though the BBB was not set up correctly. I would suggest to the customer to follow the steps in the quick-start tutorial posted here: https://e2e.ti.com/support/dlp/f/94/t/621466. Once everything is set up, then i2c tools should be installed properly and the BBB will be able to communicate with the DLPDLCR2000EVM. 

    I hope this helps.

    Thank you,

    Chris