This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

TLK105L: PRU Ethernet issue AM5718

Part Number: TLK105L
Other Parts Discussed in Thread: AM5718,

I am facing an issue with receive side of PRU ethernet (MII) used in our custom board
Processor :: AM5718
PHY :: TLK105L interfaced to PRU1 of Processor
I am using this interface for raw socket communication
Processor runs Linux. I applied pin mux parameters (IO delay structure)

PHY chip establishes link (ethtool link status shows link available). It is able to transmit data (i could verify this using Wireshark). But for
receive packets in
"ethtool" show no received packets but
droppedPackets: keeps incrementing for every packet I send .Receive side seems to drop that packet. I could not identify the cause for packet drop

Since this arrangement is working on other custom boards i suspected assembly issues
1. tried touching up Components
2. replaced PHY chipset
3. replaced Ethernet transformer

None of the above resolved the issue

using "phytool" I tried MII loopback with transmit enable (0x0016h address set value 0x0140h && enable MII loopback)

In this mode too I observe same dropped packet increment in ""ethtool"". I am not sure whether this technique is correct becoz when I conducted the same experiment 

on a working board I observe the same behavior while on MII loopback.

1. I have checked voltage levels which seems fine

2. Checked all resistor values

What could be the issue??
How to debug further??

  • Hi Rakesh,

    Is this a new or an old design? We do not have active support for the TLK105L as it is a long unused device in our portfolio, we recommend you move to the design to one of the DP8382x devices. 

    Have you tried sending and recieving between two TI PHY's or between what? Please try to see if you can send and receive between two identical PHY's. What else are you interfacing with. 



  • Hi,

    Ours is an old design.

    I have tried sending between TLK105L & DP83822 both are on same board. Here too my observation was I am able to receive data at DP83822. data send from DP83822 appears as dropped packets in TLK105L non working board.

    I have tried sending from same DP83822 as above to another TLK105L here I am able to send and receive data without any issue.

    I have also tried sending data between TLK105L (non working) and a PC. Observation was ping does not work. I could send controlled data from TLK105L which was received properly in WireShark.

    I have tried comparing register values from 0x00 to 0x1F of non working TLK105L and a working TLK105L

    I could observe same register values for both.

  • Hi Rakesh,

    Thank you for the information, however, I now think the problem is with a defective PHY, could you try to solder a different TLK105L to the non-working board? 

    We do not support the TLK105L anymore so I am limited in my ability to assist the debug here. However, if one TLK105L is working and another on a identical board is not working, then I think we can determine it is a faulty part, could also be to long shelf life of component.



  • 1. As mentioned above, I have already replaced the PHY chipset (TLK105L) with a new one. Even with this change the

    behavior was exactly the same.

    2. Since the register values of a working TLK105L & non working TLK105L are one and the same can I suspect the issue could be the MII interface between Processor and Chipset.

    1. if so then I have touched up the resistors and measured their values.I could not find any issue there . so are they related to other components (decoupling etc)

    2. issues with processor BGA balls contact with pads. I have isolated those processor pins and measured resistance to gnd.. I could measure impedance values (All the points show approx 97k to gnd) no floating points observed.

    Are there any tools available at Linux side to determine the cause for dropping packets.

  • Hi Rakesh, 

    I see, if that is the case then it would be difficult for me to debug from a distance as this sounds like a hardware problem with the board. 

    I am not familiar with the Linux tools available, so I cannot comment on whether or not there are such tools. 

    If this was a new device I would be able to perform a schematic review. Sorry we cannot be of more help here with this device.