This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

DP83TC813EVM-MC: Media converter stopped working

Part Number: DP83TC813EVM-MC
Other Parts Discussed in Thread: USB-2-MDIO, MSP430F5529


I've been using DP83TC813EVM-MC eval board as a media converter from 100BASE-T1 to 100BASE-TX. After a couple of days of usage, the device stopped working.

  • board is powered through USB
  • the DIP switches are all in the UP (1) position
  • board is connected on RJ-45 through ethernet cable to an ethernet switch
  • following LEDs are illuminated on board: D8, D9, D13, D14, D16, D17, D19, D21
  • RJ-45 left LED is illuminated in orange
  • RJ-45 right LED blinks yellow occasionally, but is extinguished most of the time
  • USB COM port is active on the host PC - I can see banner below when powering on the device
  • when using USB-2-MDIO tool, I cannot read any registers from either PHY on the board (see picture) - this worked before
  • when connected via single pair to a 100BASE-T1 device, no traffic seems to get through to the RJ-45
  • device has been placed and operated in ESD safe environment
  • there have been no configuration or connection changes since the board worked last time

Is there any documentation (apart from very sparse SNVU825) related to the MSP430 firmware operation in the media converter mode? In particular - meaning of the DIP switch positions and indicator LEDs D8-D10? How to approach the debugging of this issue?

Output of the USB COM port when powering up the device:

Board: DP83TC813-Q1 Media Converter
Board Revision: 15 RGMII
DIP Switch position: SW1:1 SW2:1 SW3:1 SW4:1
Mode: 15
Schematic Revision: 15
Software Revision: 3.04
PHY Type 0: DP83867E
PHY Revision: 1
No compliance init script loaded
PHY Type 1: DP83TC813
PHY ID: 10
PHY Revision: 1
No compliance init script loaded
End of identification

USB-2-MDIO when attempting to read PHY registers: