This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

DP83TD510E-EVM: Development Board is not recognized

Part Number: DP83TD510E-EVM
Other Parts Discussed in Thread: USB-2-MDIO

Development board DP83TD510E-EVM (two devices, two WIN7/WIN10 PC) is not recognized when connected via USB. All jumper settings are default. What is the problem?

  • Please try replacing R24 with 0ohms (connected to USB) to access the USB port.

    --

    Regards,

    Vikram

  • Thank you for advice! Provided solution did help. Development board was recognized as MSP430-USB Examaple VID_2047 PID_0300.

    The next problem is that the "standalone drivers pack" that was provided in manual (there was a link to download site) does not contain drivers for such device. Maybe they are contained in full development tools pack from TI?

  • Hello Igors,

    Which driver pack are you referrring to? Can you please point me to the manual section?

    --

    Regards,

    Vikram

  • DP83TD510E-EVM User’s Guide:

    ----------

    4.1 MSP430 Driver Install the latest MSP430 driver from this website: software-dl.ti.com/.../ msp430/MSP430_FET_Drivers/latest/index_FDS.html http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/MSP430_FET_Drivers/latest/index_FDS.html

    ------------

    But this set does not contain the necessary drivers :(

  • Hello Igors,

    I see that the site is down at this moment. But I could see MSP drivers on this site yesterday. May be you can share the driver you have downloaded from the site and I can confirm if the driver is ok or not.

  • Archive content:

    Directory of C:\ti\fetdrivers

    21-Apr-21 19:48 <DIR> .
    21-Apr-21 19:48 <DIR> ..
    21-Apr-21 19:48 0 b
    16-Apr-21 12:19 <DIR> emulation
    16-Apr-21 12:19 <DIR> install_logs
    13-May-19 12:27 160,544 MSP430_USB_Drivers_Software Manifest_WIN.pdf
    16-Apr-21 20:43 <DIR> uninstallers
    2 File(s) 160,544 bytes

    Directory of C:\ti\fetdrivers\emulation

    16-Apr-21 12:19 <DIR> .
    16-Apr-21 12:19 <DIR> ..
    16-Apr-21 12:19 <DIR> drivers
    0 File(s) 0 bytes

    Directory of C:\ti\fetdrivers\emulation\drivers

    16-Apr-21 12:19 <DIR> .
    16-Apr-21 12:19 <DIR> ..
    16-Apr-21 12:19 <DIR> msp430
    0 File(s) 0 bytes

    Directory of C:\ti\fetdrivers\emulation\drivers\msp430

    16-Apr-21 12:19 <DIR> .
    16-Apr-21 12:19 <DIR> ..
    16-Apr-21 12:19 <DIR> DPInst
    16-Apr-21 12:19 <DIR> USB_CDC
    16-Apr-21 12:19 <DIR> USB_eZ-RF
    16-Apr-21 12:19 <DIR> USB_FET_Win7_8_10_64
    0 File(s) 0 bytes

    Directory of C:\ti\fetdrivers\emulation\drivers\msp430\DPInst

    16-Apr-21 12:19 <DIR> .
    16-Apr-21 12:19 <DIR> ..
    13-May-19 12:27 552,528 DPInst.exe
    13-May-19 12:27 1,047,632 DPInst64.exe
    2 File(s) 1,600,160 bytes

    Directory of C:\ti\fetdrivers\emulation\drivers\msp430\USB_CDC

    16-Apr-21 12:19 <DIR> .
    16-Apr-21 12:19 <DIR> ..
    13-May-19 12:27 59 installCerts.bat
    13-May-19 12:27 17,842 msp430tools.cat
    13-May-19 12:27 4,019 msp430tools.inf
    13-May-19 12:27 4,245 USB_CDC_CERT.p7b
    4 File(s) 26,165 bytes

    Directory of C:\ti\fetdrivers\emulation\drivers\msp430\USB_eZ-RF

    16-Apr-21 12:19 <DIR> .
    16-Apr-21 12:19 <DIR> ..
    13-May-19 12:27 17,151 430cdc.cat
    13-May-19 12:27 2,822 430CDC.inf
    13-May-19 12:27 56 installCerts.bat
    13-May-19 12:27 4,245 USB_eZ_RF.p7b
    4 File(s) 24,274 bytes

    Directory of C:\ti\fetdrivers\emulation\drivers\msp430\USB_FET_Win7_8_10_64

    16-Apr-21 12:19 <DIR> .
    16-Apr-21 12:19 <DIR> ..
    13-May-19 12:27 525,792 difxapi.dll
    13-May-19 12:27 8,637 ump3410.cat
    13-May-19 12:27 14,336 umpf3410.i51
    13-May-19 12:27 56,320 umpusbvista.sys
    13-May-19 12:27 5,276 usbuart3410.inf
    13-May-19 12:27 1,721,576 WdfCoInstaller01009.dll
    6 File(s) 2,331,937 bytes

    Directory of C:\ti\fetdrivers\install_logs

    16-Apr-21 12:19 <DIR> .
    16-Apr-21 12:19 <DIR> ..
    16-Apr-21 20:43 9,172 ti_msp430driver_setup_1.0.1.1_install.log
    1 File(s) 9,172 bytes

    Directory of C:\ti\fetdrivers\uninstallers

    16-Apr-21 20:43 <DIR> .
    16-Apr-21 20:43 <DIR> ..
    16-Apr-21 20:43 5,764 ti_msp430driver_setup_1.0.1.1.dat
    16-Apr-21 20:43 6,323,203 ti_msp430driver_setup_1.0.1.1.exe
    2 File(s) 6,328,967 bytes

  • I am double checking but these should work.

  • Is the issue resolved? Did you try using usb-2-mdio tool to read/write register? I checked and EVM should have pre-flashed MSP430 code and you should be able to read write register using usb-2-mdio tool. If for some reason, MSP is not responding then you can flash the attached by following the user guide.msp430-usb2mdio-firmware-2.7.txt