This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • Resolved

TCAN1042HG-Q1: Schematic review

Intellectual 1860 points

Replies: 8

Views: 238

Part Number: TCAN1042HG-Q1

Hi team. My customer use 1042 between MCU and TPS92662-Q1. Supply is from UJA1169. Customer finds that the device will break sometime, and TJA1044 always works properly in below circuit. Please help review if there is anything that can cause our device to fail. Thanks.

  • Charles,

    Can you give some detail on how the device breaks? That is, what is indicating a failure/breaking in performance?

    Regards,

    Eric Hackett

    Texas Instruments | INT-TRX| Applications Engineer

  • In reply to Eric Hackett:

    With the same source code of MCU, our device cannot get any feedback data from TPS92662-Q1. While TJA1044 can. I may need your help to review this schematic and give me some suggestion to do debug. Thanks.
  • In reply to Lin_Charles:

    Charles,

    This could be due to very slight timing differences between the TJA1044 and TCAN1042, but I think it's more likely that it is a CAN signal issue. I have a few questions:

    • There doesn't look to be anything wrong with the schematic, nothing that would cause signal integrity issues.
    • Can you send over any oscilloscope screenshots of the CAN bus signals, RXD, and/or TXD of the feedback data that isn't being received correctly?
    • It looks like the TPS92662-Q1 outputs to TXD and RXD of the CAN transceiver, then the messages go along the CAN bus to another transceiver and then to the MCU. Is my understanding of the system correct? If so, are the same transceivers being used at both spots?

    Regards,

    Eric Hackett

    Texas Instruments | INT-TRX| Applications Engineer

  • In reply to Eric Hackett:

    Charles,

    Is there any update on this?

    Regards,

    Eric Hackett

    Texas Instruments | INT-TRX| Applications Engineer

  • In reply to Eric Hackett:

    Thank you for your help here. I do not have oscilloscope screenshots of the CAN bus signals. There are two CAN transceiver between MCU and TPS92662, TCAN1042 (TJA1044 )in the MCU side and UJA1163 in the 662 side. Will It matter in this issue? Thanks.
  • In reply to Lin_Charles:

    Charles,

    Getting oscilloscope screenshots of the CAN bus while this device isn't working will be very helpful in debugging this problem, so if there's any possible way for you to get hem, that would be great.

    The UJA1163 and TCAN1042 (TJA1044) being between the two controllers should not cause any problems. There are only minor timing differences between the TJA1044 and TCAN1042, so I'm not sure why one would work on the other.

    Is there any possible way to get any kind of probe information on the TCAN1042 and TJA1044 while in use? What is the data rate being used in the application? Does the TCAN1042 ever work, and how long before it stops working?

    Regards,

    Eric Hackett

    Texas Instruments | INT-TRX| Applications Engineer

  • In reply to Eric Hackett:

    Hi Charles,

    Have you had a chance to look into this further, following Eric's suggestions above? I think this is important for us to debug the issue.

    Thank you,
    Max
  • In reply to Max Robertson:

    Hi Max,

       Thank you for your help here. I need to find opportunity to do test in customer side. Will update it to team if any result got.

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.