• TI Thinks Resolved

TIC12400-Q1: Might the chip been damaged by me turning the 3V3 logic power off and the microprocessor still trying to write to it??

Mastermind 44100 points

Replies: 1

Views: 58

Part Number: TIC12400-Q1

e2e, 

I’d just like to try to clarify something with you…. As you know we have a TIC12400Q1 device in our design. Previous builds of the board have worked fine and the processor successfully gets data from the TIC device via the SPI. However, on the latest spin of the PCB I am having a few problems with the SPI data output from the TIC. This new version of the PCB is almost exactly the same as the previous version of the board except that I use a TPS27081 device to cut the 3.3V power to certain chips on the PCB (such as the RS485 interfaces, EEPROM devices and the TIC12400).

In the TIC12400 data sheet it says :

 

 

Will this cause a problem if I have 24Vdc supplied to VSS (pins 37 & 38) but no 3.3V on VDD and data is still being sent by the processor (via the SPI) – the reason I ask is that with the 3.3V enabled (logic supply on) I am seeing a very low output  drive from my TIC12400 device (only about 250mV) from the Serial output interface back to the processor (SO – pin 18). Might the chip been damaged by me turning the 3V3 logic power off and the microprocessor still trying to write to it?? I am seeing this on both of my prototype boards – so I am just looking for clues before I go in with the soldering iron ☹

 

Many thanks, 

Adam

  • Hi Adam,

    Yes, as shown in the highlighted text in the datasheet snapshot above, VDD must have 3V3 logic present while the microprocessor is still writing to the device to avoid excessive leakage currents and corrupted SPI I/O logic levels.

    Thanks

    Saminah