This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • Resolved

VAYU EVM XC5777X can't boot over uart3

Prodigy 120 points

Replies: 3

Views: 857

We have one J6 product need to boot up. I do some test on the VAYU EVM XC5777X  EVM. I can't boot up this board over uart3. I refer to the following document to do the uart booting.

I have do the resistors change for uart3. There is "VA!" print on the serial console. But after transmit the u-boot-spl.bin, there is no logs after reopen the serial console. The command I used:

D:\POC\ti_tools>D:\POC\ti_tools\serial-boot.pl -p com83 -s D:\POC\ti_tools\u-boot-spl.bin

I use the source code from 6AL.1.2 release. The address is following:

BR

jianyi

  • Hi Zhi,

    You follow instructions how to boot from UART3 in GLSDK, but using Android source! I think this mismatch is causing you these troubles. The instructions from the DRA7xx GLSDK software developers guide are valid for GLSDK source, not for Android.

    Download and install the latest GLSDK and use it as a source for the u-boot-spl.bin file.

    Regards,
    Pavel



  • In reply to Pavel Botev:

    Ok, Thanks a lot for your support.  I will download the GLSDK and have a try.

  • In reply to zhi Wang1:

    After using the newest GLSDK,  the board can be boot over UART, thanks for your great support.

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.