This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

DK-TM4C129X: Display Not Working

Part Number: DK-TM4C129X

I had purchased DK-TM4C129X from Mouser electronics.
Invoice No: 62549625
Received on : 18-07-2020

After powered the DK through USB debug port, Display is not functioning - Flickering observed

Checked with QS_Weather sample program - still not working

UART Echo sample program working

IDE- Code composer studion 10.4

Two items missing as per station list.

1. USB Micro-A plug to USB-A receptacle cable

2. USB Flash drive


  • Hello Arjunan,

    You mention receiving this kit on 18-07-2020, how often has it been used since arrival?

    Regarding the missing items I believe we need to update the kit list on still, I will look into that. There are a few items not being included now but I don't recall specifically which ones they are. I will verify and then get the website updated.

    Best Regards,

  • Sorry typo, It was received on 18-07-2021,

    I had tested the kit on 19-07-2021

    soon after testing I posted the status to mouser - distributor and got routed to TI forum

  • Hello Arjunan,

    It sounds like a defective screen to me but to be sure have you tried loading the blinky project to ensure the board is being programmed correctly and can execute code?

    The other example I'd recommend to try is the hello_widget example.

    Best Regards,


  • Hi Ralp,

    I tried the following examples

    1. hello_widget -  not working

    2. qs_Weather - not working

    3. uart_echo - working

    4. pwmled_DK_TM4C129X_TI - working

    5. mutex_DK_TM4C129X_TI - working

    6. gpiointerrupt_DK_TM4C129X_TI - working

    The controller is working in  debugging mode as well as from flash memory.


    Arjunan Anandan

  • Hi Arjunan,

    I'm going to guess the uart_echo is working in that it echoes serial port data but the LCD doesn't work?

    If so, then I would think its a bad LCD and you would need to RMA the EVM.

    Best Regards,