This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

LM3S programming using LM Flash Programmer under W10

Other Parts Discussed in Thread: UNIFLASH


I am trying to help a client with programming of an LM3S9B92-IQC80-C5 using the LM Flash Programmer under Windows 10. Currently they use an ancient XP laptop, a Luminary Micro BD-ICDI-B board, and the LM flash programmer. They want to move their programming process to a W10 laptop. I have installed the LM flash software on their W10 laptop, but when I run the programmer, I get an error message that says "**ERROR**: Unable to find a target!" I concluded that this is due to missing FTDI drivers, so I went to the TI web site and attempted to download them from here: Unfortunately that results in an error (from Firefox) that says "We can’t connect to the server at". This leads to the following question: is the driver bundle still available, and if so, where can I find it?

Since the LM FTDI drivers don't seem to be available, I tried downloading the Stellaris ICDI drivers, thinking they might be compatible. However, peeking at the .inf files in that package suggests to me that those drivers are meant for a different board(s), as the USB PIDs don't match the BD-ICDI-B board, which has a USB VID:PID of 0403:bcda. Note that this is based on my very limited understanding of Windows drivers. I've considered hacking the PID in the .inf files, since I'm guessing that these are just rebundled FTDI drivers, but that's really something I'd prefer not to do.

If the file is no longer available, what might be the fastest path to a W10 programming solution for the LM3S9B92? The client is familiar with the LM Flash Programmer, so I'd like to stay with that if possible. Is there a board or pod I can buy from Digikey or Mouser that will do what I need?



PS: When I try to enter LM3S9B92 in the Part Number field of the Create new thread form, it is not recognized as a valid part number, so I had to leave the part number field blank.

  • Hi,

      First of all, LM3S9B92 was EOL'd for quite a while. 

    so I went to the TI web site and attempted to download them from here: Unfortunately that results in an error (from Firefox) that says "We can’t connect to the server at".

    Can you try again? I just tried it and I have no problem to download I cannot attach here because this package is under export control. You need to fill out the form before you can download.  I find the old Uniflash v3.4.1 will support LM3S for programming the flash. You can download it. See below. 

    Once you use download Uniflash 3.4.1 you can select the debug probe you have (.e.g. ICDI, XDS100 or XDS200 and etc) to program LM3S9B92. Hopefully the old Uniflash version has the right drivers for FTDI.  

  • Thanks for the response. I still can't connect to when I try following the LM FTDI driver download link. However...

    # This is the download link for the LM FTDI drivers found at
    # I removed the "-1" from the server name, such that the URL looks like this:

    By browsing to the modified link, I was able to download the LM_FTDI_DRIVER package. In your copious spare time, you might try downloading the LM_FTDI_DRIVER package from outside of TI. Perhaps is only accessible on internal TI networks.

    Anyway, after installing the drivers, I was able to use the LM flash programmer to program the target board. Unfortunately this proved to be very unreliable. Often after a successful operation (blank check, verify, program, etc.), subsequent operations would fail with a can't connect to target message. Due to the flaky behavior of the LM flash programmer, I decided to try your suggestion of Uniflash. After installing and configuring it, I was able to perform all the common operations without any hiccups. One minor configuration issue I had to deal with was my file format. With LM flash we were using a binary file. Uniflash didn't seem to know what to do with this. I used the srec_cat tool to convert it to an srecord file. This seemed to satisfy the Uniflash tool.

    # Uniflash 3.4.1 doesn't like S5 records.  The -disable=data_count
    # option prevents S5 and S6 records from being generated.
    srec_cat code.bin -bin -disable=data_count -o code.srec

    Thanks for the suggestion of using an old version of Uniflash. I never would have found that on my own.