This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

Error 135 while flashing TMS570LS3135 with nowFlash v3.41

Other Parts Discussed in Thread: TMS570LS3135, TMS570LS2125, TMS570LS3137, RM48L950


I've some problems flashing a TMS570LS3135 device with nowFlash v3.41. I use a Spectrum Digital XDS510USB debugger and get the following error message:

A quick check of the nowFlash.cfg file shows, that the device ID 0x802AAD05 identifies the configuration sections for a TMS570LS3137, a TMS570LS2125 and a RM48L950. I am not sure which of these sections is applied but no configuration sets the right cpu frequency for this device which I've overwritten from the nowFlash GUI to be 160MHz:

I'he also checked that "Scan Chain 0" is disabled and Big Endian is enforced in the configuration of the XDS510USB. I also tried to use the -w option with values from 1 to 10 with no success.

Could someone give me a hint, whats going wrong here?

Thanks in advance,


  • I don't see anything wrong in your configuration.

    1) Can you tell me which board are you using? the USB stick or the bigger development board (around 10cm x 10cm)? 

    2) If you are using your own board, could you please check the VCCP (VPP) pin voltage, it should be 3.3v.

    3) In your case, you should be able to connect to the code composer (CCS). In CCS, Can you try to erase/program the flash?

    Let me know the answer, so that I can help in further.



  • This is a custom PCB, VCCP is 3.3v and I am able to flash the board with a Lauterbach debugger but not with the XDS510USB. Since we are not using Code Composer Studion in this project (custom make in combination with Eclipse) this is no option for me.

    What exactly does the error message 135 mean?

    Kind regards,


  • This error means the erase/program does not finish/response in a certain time. Usually,

    From hardware, it could be the VPP out of range.

    From software, the program code hangs on some loop. I saw this lots of times that it hangs on the memory init routine for some reason that I don't understand too.

    Can you try to assert nRST when you run nowflash. The following post explains this approach in details:

    And let me know if it solves your problem.



  • Dear Haixiao!

    The problem seems to be solved. We had a problem with a pullup resistor on the nTRST pin of the JTAG interface. Thanks for your help.

    Kind regards,


  • I see.

    If you use the Keil or IAR compiler, you need a 1k pull up on nTRST pin.

    If you use the USB510, XDS100, you do not need to do anything on this pin (actually, you need a pull down and it is built in the MCU).