This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

STELLARIS_ICDI_DRIVERS: WUDFUpdate_01009.dll Is Corrupt - Can't Unzip Stellaris ICDI Driver...


Good day folks, 


I'm trying to install the Stellaris ICDI Drivers to use the TM4C123 Launchpad and I get Unzip errors for the WUDFUpdate_01009.dll file. 


I tried both the current and archived versions from here:


Has anyone else seen and gotten past this? 


Many thanks, and best! 


  • Hello Eric,

    I haven't heard of this issue occurring before, can you please inform what Operating System you are using?
  • Hi Ralph, thanks for your response!

    I am running Windows 7 Enterprise, 64 bit

    I am also trying the full SW install to see if that makes a difference. It looks like going that route has a patch available related to signing of the Windows Drivers.

  • Hello Eric,

    Thank you. I am very surprised to hear Windows 7 as we haven't had any reports of issues with a large user base on Windows.

    Do you think any company security policies, anti-virus software, etc. could be possibly interfering? What program are you using to unpackage the .zip?

    I just downloaded and unzipped on Win 10 just fine and I can try Win 7 in the evening as well just for a sanity check.

    If by full SW install you mean TivaWare from SW-TM4C, that won't have the ICDI drivers with it, they are offered separately.
  • Hi Ralph,

    It might be policies of some kind, thought the failure message is not indicating that (maybe deliberately on my end?).

    I'm trying the full install with a patch and I'll cross the ICDI bridge when I come to it I guess!

    Many thanks for your support, I'll come back if I can't work around it. Have a great Fourth!

  • Hi Eric,

    Going more from my years of dealing with computers and Windows, to me the error sounds along the lines of 'hey I think there is a bad file in this .zip, I am not going to open it for your own safety'. A .zip unpacker shouldn't be able to tell if a dll is corrupt. Usually you'd get such an error as a Windows error where Windows is saying 'hey I tried to execute this .dll, but something is wrong'. So combine that with this yet to having occurred before from any searches I did on E2E as well as Google, I am thinking it's something related to anti-virus, Windows Defender, or even just a .zip unpacker being too smart (not sure what you use, but 7Zip works well for me).

    Anyways, I'll mark this one resolved for now.