This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

TMDXRM57LHDK: The SPI2 signals do not appear on the J10 connector of TMDXRM57LHDK Hercules Development Kit

Part Number: TMDXRM57LHDK
Other Parts Discussed in Thread: HALCOGEN


I need to use the SPI2 on TMDXRM57LHDK: RM57L Hercules Development Kit (HDK)

But the different signals do not appear on the J10 connector.

Is it necessary to initialize special part on the board?

Thanks for your Help



  • Hello Jerome,
    To use SPI2/MiBSPI2 you have to enable corresponding driver in HALCoGen Driver Enable tab (Enable MIBSPI2 driver or Enable SPI2 driver). If you are going to use MiBSPI mode then MIBSPI2 checkbox in PINMUX has to be checked also and conflicts must be cleared. Then you can use APIs generated by HALCoGen.

    Best regards,
  • Hi Miro,
    Thanks very much for your fast reply.
    All the SPI Drivers are correctly enabled.
    I did the same operation (with Halcogen or directly by program) for all MIBSPI/SPI (1 = => 5)
    All signals appear on different connectors except for the MIBSPI2. I try the operation on another board and it’s the same thing. The MIBSPI2 is connected to the micro SDCARD and there is a jumper to validate it. I tried to disable the SDCARD by the jumper but it’s the same thing.
    My question is about initialization on the board, not inside the MINSPI.
    Thanks for your help.
  • Hi Miro,
    All other MIBSPI work well and are not enabled in Alcogen.
    But to be sure I tried to enable the MIBSPI2 in the pinmux with Alcogen.
    That solves the problem.
    All works well now.
    Thanks for your help.