This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

BOOSTXL-EDUMKII: Board pulsing and causing CCS to not compile

Part Number: BOOSTXL-EDUMKII
Other Parts Discussed in Thread: MSP-EXP430FR6989, MSP-FET430UIF, MSP-FET, TEST, MSP-EXP430FR5994, MSP430FR6989

Hello,

I am using the MSP-EXP430FR6989 in conjunction with the BOOSTXL-EDUMKII for My Microcontrollers class.

I believe that the issue is the BOOSTXL-EDUMKII, this is due to behavior of the BOOSTXL-EDUMKII regardless of a compiled code or a code communicating to it.

When attached to the MSP-EXP430FR6989 regardless of an active running code, the BOOSTXL-EDUMKII pulses the LCD Screen, buzzer, RGB LED, and green 3V3 PWG led. (image 2 & 3)

It also caused the MSP-EXP430FR698's LED102 (green top light) to turn off on eZ-FET. (image 2&3 when attached regardless of compiled code)(image 1 when not attached and code is compiled)

When attempting to compile any code with the BOOSTXL-EDUMKII attached an error message is displayed

Error initializing emulator:
A firmware update is required for the MSP430 Debug Interface (MSP-FET430UIF / MSP-FET / eZ-FET). Click the "Update" button to update the firmware and launch your debug session (this may require several update steps).

When updated or resent the compiler resends the same error

When ignored a new error is displayed

Error initializing emulator:
Could not set device Vcc.

I also tried using the project Clean command: with the BOOSTXL-EDUMKII and MSP-EXP430FR6989, with the MSP-EXP430FR6989, and just the CCS by itself with no result.

I would like to note that this issue was present when I first attached the MSP-EXP430FR6989 and the code was not compiled.

I plugged in the cable to my computer attached the BOOSTXL-EDUMKII to the MSP-EXP430FR6989 than plugged the cable into the MSP-EXP430FR6989.

Another thing as this is a class, no other student has reported this issue happening to them.

This further leads me to believe that this may be a hardware issue on my BOOSTXL-EDUMKII, not a compatibility issue or a code issue.

I would appreciate any insight or advice to remedy this problem.

  • 1. Can you plug the BOOSTXL-EDUMKII to another launchpad?

    2. As I check the SBW pin will not be connected to BOOSTXL-EDUMKII, it should not affect the programming.

    3. Another reason is that the LCD and LED on BOOSTXL-EDUMKII will only be enabled by the pin on FR5989.

    4. The only thing on BOOSTXL-EDUMKIII can think of will affect the performance, is that there is shortage on the board. I think you can test the current consumption by removing the jumper.

  • Hello sorry for the delayed reply I had to wait until the lab opened to use their spare equipment.

    1) When plugged into another board the BOOSTXL-EDUMKII has the same issue and when a different BOOSTXL-EDUMKII is used it works fine.

    Meaning the problem is in fact with the BOOSTXL-EDUMKII.

    2/3) I believe that some integrated safety may terminate the connection between the MSP-EXP430FR6989 and the computer terminal to prevent damage.

    4) As I don't have the technical experience, time, and confidence to diagnose and to repair the board properly (I just started learning about the BOOSTXL-EDUMKII and have a new lab every week), is there a way I can get the board replaced?

    I appreciate your support and insight in this matter,

    Michael R.

  • I think you can find help in this website:

    You can make a call. As this is not for technical problem. I will close this thread.

    Eason

  • I am having this same issue, however I am using the MSP-EXP430FR5994. Did you ever find out what the problem was?

  • Unfortunately my board did not work out of the box. As I did not have the time, experience, or equipment to properly diagnose the board I was not able to determine the cause.

    I ended up getting a replacement board and it works just fine.

    I did hear that another student plugged their board into their MSP430FR6989 (already plugged in) and smoke was visibly seen, It then had the same exact issue.

    So my best guess without doing a proper diagnosis is there was likely a preexisting short or a blown fuse in the BOOSTXL-EDUMKII.