This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

TMS320F280045: JTAG connection error with Blackhawk isolation adapter

Part Number: TMS320F280045


I'm experiencing problems using my XDS200 debugger with the F280045 on a custom board, connected via a Blackhawk isolation adapter. Basically I am experiencing the exact same behavior reported in the thread. Main difference is I'm using an XDS200 debugger instead of XDS110, and my target is different.

Here is a screenshot of my target config:

Here is the schematic showing the connections from the JTAG port to the MCU:

When I test the connection without the isolation, everything passes. But when I try with the isolation, I get the 'SC_ERR_PATH_MEASURE' error:

I've tried decreasing the JTAG clock frequency, but it doesn't help. If I turn it way down (like below 500kHz) I get this error instead:

I've tried this with two different debugger/isolator combos, same results. I've had no issues using the same debugger/isolator when debugging other boards using the F28379D, so I don't think the debugger/isolator is at fault here. But my application will require isolation in the near future, no way around it.

Please advise

  • Mike,

    On the same board, you are able to get connect without isolation barrier?

    Is this the whole circuit related to JTAG?



  • Hi Manoj,

    Yes, without the isolator, I can connect to the target on the same board. But for later stages of development the isolation is necessary.

    That schematic shows all the connections from the 14-pin JTAG header on my custom board.



  • Mike,

    From your screenshot of the CCS setup, you are using 2pin advanced mode of cJTAG(vs the 4 pin cJTAG standard mode).  In this mode there is only TCK and TMS, and TMS will be bi-directional. 

    This would be the major difference from the full JTAG implemented on the F2837x device; and if the isolator is uni-directional (if it was copy/paste from the previous design) would give the issue.

    Since you have connected all the JTAG signals, can you try and switch the CCS setup from 2-pin advanced to cJTAG 4-pin mode?  This still reduces the signal count vs the full JTAG standard, but I believe should preserve the uni-directional nature of each pin to match what was on the F2837x.