This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

LAUNCHXL-F280049C: LAUNCHXL-F280049C + BOOSTXL-BUCKCONV TI Built-in CCS test existing project? (TI C2000Ware or C2000WARE_Digital Power)

Part Number: LAUNCHXL-F280049C


I would like to program LAUNCHXL-F280049C + BOOSTXL-BUCKCONV to just simply demo the vout at scope for now.

The TI sale website says the boostxl-buckconv is very compatible with Launchxl-f280049c, but, I have not found any existing TI built-in CCS project can run this buck converter test module. 

1. So far, I cannot find any related CCS program in C2000WARE-SDK_4_02_00_00 can run the boosterxl-buckconv module.(let me know if i'm wrong)

2. And so far, after I downloaded the C2000WARE_DIGITALPOWER_SDK_4_02_00_00, for some reasons, I cannot import the  PowerSuite's TIDM_DC_DC_BUCK's F28004x. (looks like the CCS cannot detect it)

3. I tried to download the ControlSuite's PowerSuite. but, they dont have F28004x, they only have F28069 version. 

What is my shot here? I just want to have a CCS code to run the BOOSTXL EVA module. 

Please advises! thanks!

  • Hi,

    Due to holiday break, lot of engineers are out of office. Please expect response by next week.

    Please take a look at the solution at:


    Regards, Santosh

  • Hi,

    It is available in DPSDK 4.02, shown below.

    It is supported with LAUNCHXL-F280049C.

    I am also able to import the 49C based code by clicking the "Import F280049C project " in the screenshot below.

  • Hello, 

    I'm able to get the your attached page, but I don't see the project is being added after I click on "import F280049C project", attached the page after i clicked on it.

    Then, if I clicked on browse software and examples, it kinda circled back to the first attached pictures.

    Still not sure how to do this.

  • I am not sure what is going on with that, which seems like a software installation issue. Please try install the DPSDK or CCS if necessary.