This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

LAUNCHXL-F28069M: LAUNCHXL-F28069M: i2c connection between eeprom, no response on SCL

Part Number: LAUNCHXL-F28069M
Other Parts Discussed in Thread: C2000WARE

Hi team,

 I'm trying to establish I2C communication between  the LAUNCHXL-F28069M and EEPROM, I’ve tried various codes along with the example codes present in C2000WARE but unfortunately I’m still struggling to set up the communication between Micro-controller and EEPROM, I’ve tried using other Sensors based on I2C, have verified connection and code over hundred times, external pull-ups, other reference codes,  I’ve also toggled SDA and SCL from 28 (SDA) & 29 (SCL) to 32 (SDA) & 33 (SCL) but nothing so far has been in favour, I’m receiving garbage data at SDA and my SCL doesn’t show anything.

 I’ve tride code with polling and non polling method, fifo and non fifo, also have tried code from “e2e.ti.com/.../773846” but couldn’t find success.

My circuit is as below:

Can you please help me with matter?

 

Thanks & Regards,

Divyesh Patel

  • Hello Divyesh,

    Is the SCL never going low at all? I'm confused how any data is being transmitted if this is the case, even if you are just reading garbage data (unless you're reading the default register values in the F2806x). Can you double check the ATMLH7262FC device and verify that you are using the correct pins on it? Please share its schematic here if possible. The GPIO you selected for the F2806x here are correct, so that would be my next consideration.

    Best regards,

    Omer Amir