This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

TMDSDOCKH52C1: CortexM3: File Loader: Verification failed: Values at address 0x00000020

Part Number: TMDSDOCKH52C1
Other Parts Discussed in Thread: UNIFLASH, CONTROLSUITE

Hello everyone,

unpacked my newly concerto F28M35x kit and created new project in CCS (just main file , default project for Cortex and C28) and after building C28 loads fine but Cortex gives nasty message:

Cortex_M3_0: GEL Output: Memory Map Initialization Complete
Cortex_M3_0: GEL Output: Watchdog Timers Enabled
Cortex_M3_0: GEL Output: UARTs Enabled
Cortex_M3_0: Loader: One or more sections of your program falls into a memory region that is not writable.  These regions will not actually be written to the target.  Check your linker configuration and/or memory map.
Cortex_M3_0: File Loader: Verification failed: Values at address 0x00000020 do not match Please verify target memory and memory map.
Cortex_M3_0: GEL: File: C:\Users\user\workspace_v8\Demo_Cortex\Debug\Demo_Cortex.out: a data verification error occurred, file load failed.

Uniflash memory browser looks like:

I have not programmed any settings or anything at all, just tried to run debug (to load flash).

I am using:

Code Composer Studio Version: 

Windows 8.1 Pro

Thank you for helping out in advance.

  • I have found file in my controlSuite called F28M35H52C1_m3.cmd and I have copied it into my project, and started the debug and it worked.
    I don't know why project skeleton from CCS8 didn't do it for me after I have selected microcontroller and made all settings correct.
    As I said it works, but really I don't have a clue why this should work and default one shouldn't.
    If anyone could explain why please do it, and I will mark this solution as worked for me (but still don't think it is right answer).
  • Nikola,

    Thank you for notifying us on this. I agree that the ARM project is not pulling in the default linker command file for this device when you create the project. C28x project looks fine.

    Since, there is no any linker command file, Linker might have chosen some default ARM specific memory map and hence you got those warnings in the failing case.

    I will notify this to our CCS team.

    Thanks again for notifying us.

    Best regards,