This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

TIDM-BIDIR-400-12: TIDM-BIDIR-400-12, eeprom, ftdi, xds100v2

Part Number: TIDM-BIDIR-400-12
Other Parts Discussed in Thread: TMDSCNCD28035, TMDSCNCD28035ISO, CONTROLSUITE, C2000WARE, TMDSCNCD28069ISO

Hello, community members.

I'm now following TIDM-BIDIR-400-12 design. 

Last thread() I had a problem with writing xds100v2 driver into eeprom. 

In windows, I can see that the USB connection is well connected. (windows 10 and RS4)

I checked all the hardware connection point, but there was no problem. 

I tried to solder the new PCB and hardware one but had the same problem. 

I hope anyone can help me. 

Thank you again. 

  • Kim,

    It is Thanksgiving week in US. Most of the TI engineers are on vacation. Please expect delays in response.

    I would realistically expect a response back from TI early next week.

  • Hi Kim,

    I'm going to list out some of my assumptions based on reading your post first:

    • As in your linked post, you're now trying to connect to the F28035 device via the on-card emulator on this ISO controlCARD (and not the one on the baseboard).

    If so, here's some things I would recommend:

    1. For the baseboard: If you have a USB cable plugged into E:JP1, go ahead and remove it.  This will reduce the chances of your computer potentially getting confused on which emulator to talk to.
    2. For the baseboard: Remove jumper J13, if currently placed.  This will disable the emulator on the baseboard and keep it from potentially creating contention on the TRSTn signal.
    3. What program are you using to try and reprogram the on-card emulator?  Note that the emulator on this board is an xds100v1, not an xds100v2.  These emulators are both based on FTDI chips & are similar, but a bit different - and may be why you are seeing the error that you are.  As such, you may want to try to look at the following:

    Hopefully this helps!  Good luck!

    Thank you,

  • Thank you for your kind help.

    I think my situation is not well explained.

    1.  I'm now following TIDM-BIDIR-400-12 design

    2. I 'm using TMDSCNCD28035 dsp for design above.

    3. I set up PCB , soldered the component.

    4. I'm now following tiduai7 document, section 6.1.1

    5. in section 6.1.1, they said,

           "6. If this is the first time the board is being tested with JTAG connection, run the program_ftdi.bat file in

             the file to program the FTDI chip on the board."

    6. because I soldered the empty eeprom, I should install the above.

    7. windows 10 rs4 is installed on my laptop, I run the 'program_ftdi.bat' then I get the error I mentioned above.

    After I got the recommendation, I checked my jumper E:JP1, J13, but it is already disabled. 

    If I enable J13 jumper, has another error message called 'out of index, device 0 not exist'

    Thank you for your help.

  • Hi,

    Two Questions:

    1) With your new post, I'm now not sure.  Which are you using as your controlCARD?
    (TMDSCNCD28035 or a TMDSCNCD28035ISO?)

    2) Can I assume that you procured blank PCBs and then had the baseboard assembled/soldered, based on the provided design files?
    If so, what do you see within Window's Device Manager currently?

    Thank you,

  • Thank you for your reply. 

    1) I'm now using TMDSCNCD28035

    2) Yes exactly. 

    First figure is before i plugged in USB cable with pcb

    Last figure is after I plugged in USB cable with pcb

    Thank you. 

  • Hi,

    OK.  I believe I now understand the full situation.  I have a few different thoughts on ways to debug.  I'll try to explain my thoughts so that you can potentially do more, since we're in different time-zones.

    1) The error we are trying to resolve in this post does not have much to do with the implementation of the FTDI chip in the TI system (why is my FTDI chip not programming).  I think you may be able to get a good response on how to go about debugging by asking the FTDI engineers.  I'd recommend trying this in parallel.

    2) Based on your previous thread, you have access to a TMDSCNCD28035ISO controlCARD.  You don't need to plug this cCARD into a baseboard, but if you plug it into a USB-mini cable that is attached to a computer (and unplug the computer's connection to the BiDir baseboard) you should be able to check some things:
     a) From Device Manager, do you see the same thing that you see with the baseboard's emulator?
     b) Are you able to program the FTDI chip successfully on the cCARD? 

    [The ISO cCARD's circuitry was assembled by a manufacturer, so if both emulators show the same behavior I'm going to hypothesize that something may be wrong with your computer/its drivers/etc.  However, if the ISO cCARD can be programmed that you might be able to optically inspect both emulator instances to see what might be wrong on your baseboard - my thought would be to look around the EEPROM, if this is the case]

    Hopefully this gets us closer...

    Thank you,

  • Thanks for your help. 

    1. I'll contact ftdi manufacturer as you recommended.

    2. a) I can see the figure below.

    In my opinion, it shows the well installed xds100 driver into eeprom case. 

    b) Up is the device scan with FT Prog program. with  TMDSCNCD28035ISO

    Down is the device scan with FT Prog program with my hardware. 

    Thank you for your kind help

  • I've tried one more thing. 

    I found the document called 'TMDXEVM3358-SK – FTDI FT2232H EEPROM Programming Document'

    and I got this message

    This message means same as 'Failed to program Device 0!'

    And also in ftdi manual I attached,page 43, it is because of device and template chip type doesn't match.  

    So I think I miss-assembled ftdi chip or eeprom. 

    I bought the component in digikey, and below is the exact the link I bought

    ftdi :

    eeprom : 

    Do you think these components are matched with BOM file in TIDM-BIDIR-400-12?

    Thank you for your help 

  • Hi,

    I agree that your computer looks to be working with the TMDSCNCD28035ISO controlCARD. 

    This makes me confident that there is some issue in the emulator section of the BiDir board.  Note that the issue is strictly in this section, as you should be able to reprogram the FTDI's EEPROM without the C2000 even being powered.  As mentioned in my most recent post, I'd likely suspect the area around the EEPROM, specifically. 

    Until this is resolved, you will be prevented from being able to progress on using the TMDSCNCD28035 with this board.


    Looking at your previous posts, it looks like you determined that you could not use the TMDSCNCD28035ISO with the BiDir baseboard.  What led you to this conclusion?

    The BiDir board and software was not something one that I owned/designed.  However, after designing several of these controlCARDs, I think you should be able to use the TMDSCNCD28035ISO with this baseboard.  The only thing that I'm aware of that is different between the two cards is that the TMDSCNCD28035ISO has RC-filters on all the ADC inputs (whereas the TMDSCNCD28035 only has RC-filters on only some).  However, it's probably a good idea for you to refer to the two schematics in controlSUITE/C2000Ware so that you can gain confidence & check what I'm claiming.

    Being confused on what was going on, the first post I gave in this thread was actually one where I was trying to give some key points on how I felt you could use the TMDSCNCD28035ISO on this board.  The only other key thing that I didn't mention is SW3 on the ISO cCARD will need  to be closed. 

    With all that done, I think you should be able to progress in connecting with the F28035 and beginning your BiDir experimentation.  And you'll be able to do this without needing a working emulator section on the BiDir baseboard.
    (you just may need to translate some of the directions from component names on the CNCD to those on the CNCDISO)

    Thank you,

  • Sorry, just noticed your points on being unable to program the emulator on the CNCD28035ISO.  Please try using the procedure from:

    As mentioned in a previous post, the emulator on both the CNCDISO & the BiDir baseboard are actually an xds100v1 (using the FT2232D). I'll work with the owner of this kit to try and get the instructions for programming updated.

    Thank you,

  • Thanks for your help.

    So what I understand is...

    1. with FT2232d FTDI chip, I can only program the xds100v1.
    2. Instruction on TIDM-BIDIR-400-12, tiduai7.pdf(

    "If this is the first time the board is being tested with JTAG connection, run the program_ftdi.bat file in

    the file to program the FTDI chip on the board."

    is wrong

    Am I understand right?
    If it is right I should follow this link( you mentioned in last post.

    Thank you.

  • Hi,

    This is correct.

    An example of an xds100v1 implementation is the TMDSCNCD28035ISO.  Its heart is the 48pin FT2232D chip.
    An example of an xds100v2 implementation is the TMDSCNCD28069ISO.  Its heart is the 64pin FT2232H chip.

    You can refer to each's schematics within controlSUITE/C2000Ware to see the differences.


    To program a xds100v1, you should use the forum post I linked.
    (note that I believe the drivers for each are similar & may be able to be used interchangeably - in some programming methods [but not all].  This may help to explain why the instructions are incorrect.  That being said, it is always best to use the proper programming image for the FTDI you are using)

    Thank you,

  • Thank you for your kind help.

    I finally can install xds100v1 into eeprom. 

    Thank you

  • Just to confirm:
    You are able to program the FTDI on the ISO controlCARD? 
    On the BiDir baseboard as well?

  • No I'm afraid that I don't want to ruin with TMDSCNCD28035ISO card
    I success to program with BiDir basboard.
    I have another problem but I will ask with another thread
    Thank you.