The TI E2E™ design support forums will undergo maintenance from Sept. 28 to Oct. 2. If you need design support during this time, contact your TI representative or open a new support request with our customer support center.

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

LAUNCHXL-F28069M: LVSERVOMTR usage to connect to launchpad F28069M (Connectors QEP_A and QEP_B)

Part Number: LAUNCHXL-F28069M

With reference to the use of the motor (Teknic_M2310PLN04K), the cable  for the KIT is supplied with   two connectors:
J4 which is connected to the encoder included in the motor and
J10 which is connected to the hall effect sensors (may be?).
WHAT I would like to know:
J10 is used for something, and if so it is connected to QEP_A or B.
J4 which has the encoder signals + its 5V power supply is connected to QEP_ ?.

Finally, is it necessary to connect the two, or only J4 (Encoder)
Doesn't the kit start-up documentation exist?
Thanks in advance

  • J10 is hall sensor interface and J4 is QEP. Our example projects typically use QEP header only. It is not necessary to connect both of them. You can, however, use them both if configured appropriately. As such the board can support controlling two motors with one type of position encoder. If you use two types of position encoder from the same motor to the launch pad, then you can control only one motor with position feedback.

    More info about this hardware can be found at https://www.ti.com/tool/LAUNCHXL-F28069M