This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

CCS/TIDA-01281: Swapping TMS and TDO pins to match microcontroller

Part Number: TIDA-01281
Other Parts Discussed in Thread: TMS320F28035, , UNIFLASH

Tool/software: Code Composer Studio


How can the TMS and TDO of the JTAG debugger be swapped to match the TMS320F28035 microcontroller? Can the JTAG pin map be changed in CCS or must the cables physically be swapped?

Thank you,


  • Hi Sandy,

    I'm not following what you are trying to do.  Do you want to use the F28035 rather than the F28033 in TIDA-01281? These two devices are in the same family and are pin-by-pin compatible, therefore there shouldn't be a need to swap any pins.

  • In the TIDA-01281 schematic it shows the TDO and TMS labels swapped so this would make pin 1 of the J3 connector TDO and pin 7 TMS which does not match with the TI 14-pin JTAG pinout. A few other posts in the forum mention this issue but I cannot find how exactly to solve it. I am using the TI XDS110 debugger and getting the same error message as others have mentioned when trying to test the connection.

  • Hi Sandy,

    Sorry to hear about your trouble with this TI design. I looked more into it, and you are correct. There is a design error where the TDO and TMS lines are swapped. This is documented here for future reference:

    One way you could fix this is to use some jumper wire to connect the pins on the JTAG connector (J3) to the connector of the emulator you are using. This way you could swap the TMS and TDO pins between the two connectors. You would need some Male/Female jumper wire like the shown below.

  • Hello,

    I used 10cm jumper wire to swap the pins and still get this error in CCS:

    The value is '-233' (0xffffff17).
    The title is 'SC_ERR_PATH_BROKEN'.

    The explanation is:
    The JTAG IR and DR scan-paths cannot circulate bits, they may be broken.
    An attempt to scan the JTAG scan-path has failed.
    The target's JTAG scan-path appears to be broken
    with a stuck-at-ones or stuck-at-zero fault.

    and in Uniflash:

    (Error -1135 @ 0x0) The debug probe reported an error. Confirm debug probe configuration and connections, reset the debug probe, and retry the operation.

    I have removed the pull-up R18 and changed pull-down R14 on the TRST signal to 10.0k. Is the length of the jumper wires likely a problem since the signals are not buffered? Or do you have other suggestions for troubleshooting?

    Thank you,


  • Hi Sandy,

    Yes, it could be the length of the wires that is the problem. One thing you can do is see if you can reduce eh JTAG TCK frequency. You can do this in the ccxml file you are using in CCS. Open that file, click "Target Configuration" under Advanced Setup, click on the emulator you are using, and then adjust the TCLK frequency.

    Another thing you can try is to physically lift the pins on the IC on the board, and rewire them using short, clean wire. This will likely give you the best result.

  • Hi Gus,

    I used shorter wires to connect the JTAG and reduced the JTAG TCK frequency, but unfortunately I get the same error. When I run the test connection in CCS, I see on my oscilloscope either no signal from TMS and TDO or one small dip in voltage. For TCK, TDI, and TRST, I receive signals. The board is powered up correctly. I am now wondering if this could be a problem with the debugger or the IC is dead?

    Thank you,


  • Hi Sandy,

    Sorry about the troubles you are facing this this board. One thing I noticed while looking at the schematics is that pins 13 and 14 on J3 (JTAG connector) don't have a pull-up resistor. These pins correspond to the EMU0/1 pins which need a pull-up as described in the device datasheet. Pin 6 should also be grounded. Could you try adding a pull-up resistor on these pins to the 3.3V rail on the board? If that doesn't work, try grounding pin 6.

    Here is the JTAG section in the datasheet for reference.

  • Placing a pull-up on the EMU0/EMU1 pins did not work either. Also the XDS110 jtag header has no pin 6 so grounding is not needed, correct?

  • Hello Sandy,

    Sorry again for the trouble getting this board to work. A couple of additional comments.

    • In one of your messages you mentioned TMS was not toggling. This is an input to the DSP from the XDS110 emulator. Have you tried the emulator with a different board just to make sure that it is working ok?
    • You also mentioned the TDO pin was not toggling. This would indicate the scan chain is indeed still broken (but could also be due to TMS pins not toggling). Have you verified the power, reset, and clock levels on the DSP?

    Last suggestion I can think of is to physically lift the TMS and TDO pins on the device and rewire them correctly at that point.

  • Hello Gus,

    I replaced the IC and now I can successfully connect. 

    Thank you for your help.