This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

TMS320F28388D: IDDK R2.2.1 fsi ping error

Part Number: TMS320F28388D

More of a comment here than question. This is related to the suggestions found on a question asked by Arjan Oskam; "FSI example fsi_ex16_daisy_handshake fails when using FSI_DATA_WIDTH_2_LANE." I have been going through the TIDM-02006 example code. I am testing the FSI functionality with the F2838x fsi_ex1_loopback_cpucontrol C2000Ware- project. The FSI adapter board and code worked fine for the F28004x LaunchPad slave at FSI 50MHz one lane (I used the corresponding F28004 C200Ware project). I had a problem with the master TMS320f28388D control card in combination with the IDDK R2.2.1 at FSI 50MHZ one lane. With PRESCALER_VAL set to FSI_PRESCALE_50MHZ the RX ping would timeout. I tested the control card on the docking station under these conditions and it worked fine at 50MHz one lane. But on the IDDK the RX ping would timeout. First was a dumb issue of removing the J13 jumper on the IDDK which I believe was grounding the TX clock. With the J13 jumper removed on the IDDK I was only able to successfully ping at a PRESCALER_VAL of FSI_PRESCALE_10MHZ. But then as suggested by Kevin Allen18 in Arjan's post I removed the GPIO resistors off the FSI header. I was then able to successfully run the loopback project at 50MHZ with the IDDK.