This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

  • TI Thinks Resolved

DRV8301-HC-C2-KIT: DRV8301-HC-C2-KIT: Connection could not be established (exception)

Prodigy 60 points

Replies: 4

Views: 127

Part Number: DRV8301-HC-C2-KIT

Hello,

1. I just have received DRV8301-HC-C2-KIT and set the SW3 UP and launched "InstaSPIN-BLDC_GUI_DRV83xx_v104.exe"

It shows "Connection could not be established (exception)".

2. Suspected program in the Piccollo, and launched CCS.

Created new configuration and loaded "InstaSPIN-BLDC_GUI_DRV8301_v104.out", which was successful.

3. Before exit CCS, connection was tested.

When SW3 is up, it is failed. When SW3 is down, the connection test was successful.

4. CCS was installed with all the library and tools for C2000 and  Windows says that the device driver is properly working.

So, I believe what I did is not incorrect.

However, "InstaSPIN-BLDC_GUI_DRV83xx_v104.exe" still shows error  "Connection could not be established (exception)".

SW3 was set UP.  Of course, I tested both of UP and DOWN.

Please help.

Thanks in advance,

Heon Lee

  • 1. Program the "InstaSPIN-BLDC_GUI_DRV8301_v104.out" into the device using CCS, the SW should be ON (DOWN side) to enable the JTAG.

    2. Disconnect the emulator, exit the CCS, power off the board.

    3. Set the SW3 to OFF (UP side) to enable Serial communication port, SW2 position1&2 to ON (UP side) to enable Flash boot mode, connect the USB wire, power on the board, you should see the LED (LD3, RED) is flashing with about 1Hz frequency.

    4. Start the GUI.   

    You may follow the guide to use the connection wizard to set up the connection, 

    Connection->Start Connection wizard->Connect to engine->Texas Instruments->C2000:28x Piccolo Series->Piccolo 28035->Commros Transport->Serial->Connect

  • In reply to Yanming Luo:

    Thanks.

    At step 1, what is the status of SW 1&2 ?

                    what is the status of LD3 after loading the program  or before loading the program ? RED flashing 1Hz ?

    At step 2, what does it mean by "Emulator" ?    The inverter board ?

                    "disconnect the emulator" means "remove Piccolo CPU from the inverter board" ?

  • In reply to Yanming Luo:

    I succeed on Win7.  I believe windows10 was he problem.

    Now, I need to operate the system on Win10. Please provide me a solution for win10.

  • In reply to Heon Seok Lee:

    We have tested the GUI on both Win7 and Win10, it works well on Win10 also. Maybe, you have to check if there is any missed patch on the Win10 of your PC.

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.