TMDSHVMTRINSPIN: Cannot Connect or Identify USB Serial Port

Prodigy 20 points

Replies: 2

Views: 42

Part Number: TMDSHVMTRINSPIN

Hello,

I recently purchased a TMDSHVMTRINSPIN kit on Oct 16 2019 and I am just now setting up the device for the first time. I am attempting to get an initial run going with the GUI Composer InstaSPIN program that came with the included USB drive in the kit. I have followed the "Quick Start Guide: Evaluating InstaSPIN-MOTION (F2806xM) using the Graphical User Interface" document up to the point where I connect a USB port to my computer and launch the GUI. When I connect the USB, I cannot find the device in my Device Manager and when I launch the GUI, I get the error:

"ScriptingException: Error connecting to the target: emulation failure occurred"

I have a TMDSCNCD28069MISO control card installed with  SW1: UP-UP, SW2: DOWN-DOWN, SW3: UP-UP. I have verified that Jumpers J3, J4, J5, J7, J8, M3-J5, and J2 are properly configured. I have a brushless DC motor connected to ports U, V, and W. I have a banana cable from BS5 to BS1 connected. I have the 15 VDC power supply connected and the USB cable connected to J1 on the control card. When I plug in the 15 VDC power supply, M6-LD1 turns green as well as LD1 on the control card. When I connect the USB to J1, M3-LD1 turns green, however, my computer does not recognize any USB connected  (no recognition in the Device Manager). I did try connecting the AC plug after following these steps, but still no USB recognition.

How can I resolve this problem?

2 Replies

  • Can you try taking a look at this application report? It has some debug tips for common connectivity issues.

    www.ti.com/lit/spracf0

    Are you able to connect to the device in CCS?

    Thanks,

    Whitney

  • In reply to Whitney Dewey:

    When trying to connect in CCS, I set the connection to "Texas Instruments XDS100v2 USB Debug Probe", the Board/Device to "TMS320F28069", saved the configuration, then clicked the button to test the connection. This lead to the following output:

    [Start: Texas Instruments XDS100v2 USB Debug Probe_0]
    Execute the command:
    %ccs_base%/common/uscif/dbgjtag -f %boarddatafile% -rv -o -F inform,logfile=yes -S pathlength -S integrity
    [Result]

    -----[Print the board config pathname(s)]------------------------------------
    C:\Users\username001\AppData\Local\TEXASI~1\CCS\
        ccs920\0\0\BrdDat\testBoard.dat
    -----[Print the reset-command software log-file]-----------------------------
    This utility has selected a 100- or 510-class product.
    This utility will load the adapter 'jioserdesusb.dll'.
    An error occurred while soft opening the controller.
    -----[An error has occurred and this utility has aborted]--------------------
    This error is generated by TI's USCIF driver or utilities.
    The value is '-716' (0xfffffd34).
    The title is 'SC_ERR_LIB_LOAD_SERDES_DRV'.
    The explanation is:
    Required dynamic library jscserdes could not be located.
    The library isn't on the search path.
    [End: Texas Instruments XDS100v2 USB Debug Probe_0]
     I have tried re-installing controlSuite, CCS, and MotorWare with the same output.
    In regards to the www.ti.com/lit/spracf0 document, Section 3.3 puts me on a path to "Reprogram Emulation Controller". That document then points to https://e2e.ti.com/support/microcontrollers/c2000/f/171/p/252873/889381#889381, but I am unsure how to exactly execute that reprogramming... Do I need to disconnect my TMDSCNCD28069MISO controlCard from the HVMTR kit and use one of the on-card usb connections? And how do I execute a reprogramming session? Or should I focus on resolving the suspected driver problem mentioned above?
    Any help would be appreciated