This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

MSP430F6736: MSP430F6736

Part Number: MSP430F6736
Other Parts Discussed in Thread: MSP430FG479, MSP-TS430PZ100, , MSP-FET

Hi - trying to find out why I am not able to get MSP-FET430UIF to work with my version of IAR.

I used this interface (IAR/debugging tool) before to debug with MSP430FG479 and it all worked fine, where I am now using it with a MSP-TS430PZ100B (MSP430F6736 development board) and get the following error:

In addition, it won't allow normal stepping through the code.

I am using a Win10 machine and detailed info on the tools is as follows:

IAR Embedded Workbench:

debugging tool:

MSP-FET430UIF S/N: 10086554909R V1.4a

At the moment, I am just trying to get the interface to work with the 6736 part before I implement any of my code, so I am using/running sample code from TI, as follows, where the code compiles/links fine, but no matter what I run I get the same "unable to execute driver error":

#pragma language=extended
#include "io430f6736.h"

int main(void)

// Setup P1.x output
P1DIR |= 0xFF; // Set P1.x to output direction
P1OUT |= 0xFF; // Set P1.x

__bis_SR_register(LPM4_bits | GIE); // Enter LPM4 w/interrupt
__no_operation(); // For debugger

tool setup:

also for my hardware I connected a 32khz crystal on the board and I am powering my development board from the debugging tool (measure 3.34V across VCC to GND with debugger running).

any help and/or guidance will be greatly appreciated...


**Attention** This is a public forum