This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

MSP-EXP430F5529LP: Error when trying dsplib examples

Part Number: MSP-EXP430F5529LP

I have the same problem in MSP-EXP430F5529LP: Unable to complete output buffer initialization - MSP low-power microcontroller forum - MSP low-power microcontrollers - TI E2E support forums this post.

I tried the solution on  e2e china. They said " Change the project configuration to 5529 and #define MSP_USE_LEA 0" 

My configuration is already 5529 and I tried the changing MSP_USE_LEA to 0 but nothing changed.

Can you please help me I couldn't find any solution or information in anywhere.

  • This usually indicates that the Watchdog timer is expiring while .data/.bss initialization is still running ("too much" data).

    You can try setting Build Settings->Build->Linker->Basic->Hold Watchdog Timer" to "on". This disables the WDT (only) curing C initialization.

    Historically, the way to do this is to define a function something like [Ref Compiler User Guide (SLAU132X) Sec 6.9.1]:

    int _system_pre_init(void)
        WDTCTL = WDTPW | WDTHOLD; // Stop watchdog before C init
        return(1); // Finish C init

  • I tried that suggestions but non of them worked.

    After that I continued to research and in somewhere i found solution. It's caused from clock initialization, in default settings F5529 running at 1MHz, changing speed to 8 MHz(with cristal) solved everything.

    Regardless thank you for interest Bruce

**Attention** This is a public forum