This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

MSP-TS430PZ100AUSB: Launchpad is always in SUSPEND mode.

Genius 13959 points
Part Number: MSP-TS430PZ100AUSB
Other Parts Discussed in Thread: MSP430F5632

Hi Experts,

Seeking your assistance on this please:

Customer is trying to run one of your demo on MSP TS430Z100USB launchpad using MSP430F5632 microcontroller. The demo is H3 EchoToHost from MSP430USBDevelopersPackage_5_20_06_03. It builds okay and when I run it enumerates as USB HID device correctly, but when I ran the HIDDemo nothing shows up. I investigate it and the launchpad is always in SUSPEND mode. Can you help? I tried the same on other launchpad MSP EXP430F5529LP and get same results, I must be doing something wrong. But need some guidance.

Thank you.

Regards,
Archie A.

  • Hello Team,

    Any update on this? Customer is asking an update with his follow up:

    According to the USB example document, I installed V6.0 of CCS and I am able to get the H8_Keybord test to work on 5529LP lanuchpad, but when I run H1_ledOnOff and H3 echotest this fails. I am compiling with TiV4.3.1 compiler and when I debug it further it does not enter ST_ENUM_ACTIVE, it ends in ST_ENUM_SUSPEND. Thats the reason maybe the HIDdemo.jar does not show up initial screen.

    Please let me know if you need further information.

    73,
    Archie A.

  • The demo H3 EchoToHost I can enumerate the device in my PC(my windows information as below) as below

    Please help to check the drivers you installed as mentioned in the section 2.5(that is for CDC but maybe help with the hid demo)

    4113.Examples_Guide_MSP430_USB.pdf

    More information about the HID demo please refer to this doc

    HidDemo.pdf

**Attention** This is a public forum