This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

MSP430FR6047: USS-02_40_00_00-osx crashes at startup

Part Number: MSP430FR6047


Good Day.

USS-02_40_00_00-osx-installer installs successfully on M1/M2 MacOS but crashes at startup.

I tried starting to install multiple times, but the icon appears on the lower taskbar and then suddenly disappears without any error message (before any GUI window is created).

When executing it from the terminal like so:


I get the following error:


Exception in thread "main" java.lang.UnsatisfiedLinkError: no HidCommunicationManagerMac64 in java.library.path: HidManagement

at java.base/java.lang.ClassLoader.loadLibrary(

at java.base/java.lang.Runtime.loadLibrary0(

at java.base/java.lang.System.loadLibrary(

at com.ti.msp430.HidManagement.HidCommunicationManager.<init>(

at com.ti.msp430.HidManagement.HidInterface.<init>(

at com.ti.msp430.USS.HidEvents.USSHidInterface.<init>(

at com.ti.msp430.USS.HidEvents.SensorDataPacketHidInterface.<init>(

at com.ti.msp430.USS.Application.Application.<init>(

at com.ti.msp430.USS.Application.Application.main(

It did run fine on Intel-based Mac.

Machine specs:

Macbook Pro 16-inch, 2023
Apple M2 Pro 16 GB
OS: Ventura 13.3

I also tested it on the M1 machine and got the same error.

Please advise. Thank you very much.

Best Regards,

Ray Vincent

  • Hi Ray,

    Yikes, that doesn't look good. You might want to try seeing if the java versions between your intel version mac and your current mac are different. However, if the problem is related to apple silicon then I doubt this will fix it. 

    Unfortunately, this GUI is no longer being actively developed so I'm not sure what the timeline on getting a fix is.



  • Does the customer have access to a windows PC?

  • Hi Evan,

    Good Day. Please see below the response of our customer to your reply. Thank you very much.

    On the M2 machine java -version gives the:

    openjdk version "19.0.2" 2023-01-17

    OpenJDK Runtime Environment Homebrew (build 19.0.2)

    OpenJDK 64-Bit Server VM Homebrew (build 19.0.2, mixed mode, sharing)

    On intel based machine 
    openjdk version "1.8.0_292"
    OpenJDK Runtime Environment (AdoptOpenJDK)(build 1.8.0_292-b10)
    OpenJDK 64-Bit Server VM (AdoptOpenJDK)(build 25.292-b10, mixed mode)
    I have no clue about required java versions, JDKs etc.
    The version numbers on the machines don't even seem similar.
    What would be the likely latest JDK version supported?
    I have installed other versions using brew.

    Best Regards,

    Ray Vincent

  • Hi Ray,

    Thanks for sharing that. To be honest, I'm not sure if that is the root cause. The customer might try to experiment with Java versions, but we don't have M based macs to test this on right now, so I can't confirm or debug.

    Unfortunately, this probably isn't something we can support in near term.



**Attention** This is a public forum