This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

EVM430-FR6047: USS Design Center App, "HID bridge connected -- waiting for device"

Part Number: EVM430-FR6047
Other Parts Discussed in Thread: UNIFLASH, MSP-FET

I've seen other posts related to the "HID bridge connected -- waiting for device" message but none seem applicable to my specific issue. I am using what I believe is the correct water monitoring firmware (see image below) and I was prompted to and did update when installing. When I open Ultrasonic sensing design center I get the error. COM ports look as expected in device manager. I think I've got the board set up just fine (image below). Perhaps something with the D100 LED being red, although in the many attempts I've had with this sometimes it's not red so I'm not sure that's the issue. Any ideas on what else I can try to get the USS app to connect?

  • Hi,

    You can try on the following things. 

    1. Remove the jumper on the J32

    2. Remove the connection to the transducers. 

    Best regards,

    Cash Hao

  • thanks for the reply. unfortunately neither of these resolved the issue, everything seems to be behaving the same as before. 

    I noticed in the USS application an error "Pulse Generation parameters are invalid" but this is no longer showing now and the board is still not connecting properly

  • I just tried this same set up with a new EVM430-FR6047 and the same thing happened as with the first one.

    When I first flash the "MSP430FR6047EVM_USS_Water_Demo_LPM_02_40_00_00" to the EVM with Uniflash I am told I need to update the firmware:

    [ERROR] MSP430: Error initializing emulator: A firmware update is required for the MSP430 Debug Interface (MSP-FET430UIF / MSP-FET / eZ-FET). Click the "Update" button to update the firmware and launch your debug session (this may require several update steps). DO NOT UNPLUG THE INTERFACE DURING THE UPDATE.

    I did this for both boards. I also have a red D100 LED in both boards and haven't found an answer as to what that indicates.

    Any other suggestions much appreciated!

  • Hi,

    Click the update button should not cause your issue. 

    Have you tried to import the demo project in the CCS. Then build and download the project using CCS. Then check if you still get this issue. Remember when the downloading finished, you can repower the EVM board and then connect to the USS GUI.

    Best regards,

    Cash Hao

**Attention** This is a public forum