This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

TI SmartRF Flash Programmer: failed to program MSP430F2419

Other Parts Discussed in Thread: MSP-TS430PM64, MSP430F2419

System Specs:

OS: Windows 7 Home Premium 64bit
IDE: Code Composer Studio: version 5.1.1.00031
Micro-controller: Using MSP-TS430PM64 target board to program MSP430F2419

Problem Description:

I have been using Code Composer 5 for MSP430 development. I have had no problems loading programs into the
target micro-controller using the MSP-FET430UIF for debug work. I recently installed TI SmartRF Flash Programmer so I can flash program a .hex file onto the target micro-controller. The tool appeared to install correctly on my system but it does not recognize the MSP-FET430UIF emulator. When I open the MSP430 tab on the flash programmer tool it displays the following:

Status: IN USE

Port Name: COM4

Device Name: UNKNOWN

When I click the "Refresh" button on the flash programmer tool, the red LED on the MSP-FET430UIF flashes a few times then goes back to just the green LED.

 

I have seen the status change to "AVAILABLE" and show the Device Name "MSP430F2419" once. When it showed up once, it failed to program showing the message "Programming failed: Could not find device (or device not supported)"

 

  • Figured out the problem. I have a few devices connected up to the I/O pins on the target board that was some how sucking current from the JTAG connection making the micro-controller not visible to the flash programmer. The problem was solved by providing external power to the devices hooked up the micro.  Still uncertain how current was getting sucked from I/O pins. The VCC connections were separated.