Due to the U.S. Thanksgiving holiday, please expect delayed responses during the week of 11/22.

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

MSP430FR5725 BSL error

Other Parts Discussed in Thread: MSP430FR5725, MSP-EXP430FR5739, MSP-EXP430G2, MSP430G2553, MSP430G2231


I'm trying to send commands to my BSL using the MSP430 Lauchpad and BSL_Scripter. I did what is explained in the application note SLAA535A.

I think that my MSP430 is successfully entering in the BSL, but when I try to send any command with the BSL_Scripter I always get the error "0x54 - Packet size exceeds buffer. The packet size given is too big for the RX buffer"

Here is what I try to send:

DELAY 1000

The output:

BSL Scripting application 1.06
The local time is: 08:45 on 16.10.2012
Initializing, Mode: 5xx COM: COM6 DONE
Verbose mode on
Waiting 1000 milliseconds DONE

[80] [01] [00] [19] [e8] [62] {54}
BSL Version: ERROR

Whatever I try to send I get errors.

I attached the serial frame grabbed with my logic analyser.

Any suggestions ?



  • Hi Nicolas,

    this is interesting and weird. My first suggestion is that somehow the target MSP430 doesn't interpret the message bytes (especially the length bytes NH and NL) correctly. 

    Are you using a custom board for the MSP430FR5725? Have you checked the appendix part of SLAA535A where there is a table showing the connection of Launchpad to the target board? Are you using the same connections? I remember that i had similar problem and it appears that there was a grounding problem. Using the GND pin on the J6 connector of the Launchpad instead the GND pin of J2 connector somehow solve the problem.

  • Hi Leo,

    Yes I'm using a custom board, but I have the same behaviour with the MSP-EXP430FR5739 evaluation board.

    My connections are as stated in appendix and I'm using J6 for GND connection.

    Maybe I can try to check the signal integrity...



  • Signal integrity is ok.

    Connections are good, I double checked them.

    Very strange issue, I'm trying to make it works with the MSP-EXP430FR5739 and still no chance..


  • Hi Nicolas,

    do you have any other MSP430 target which you can test beside the MSP430FR57xx? I would make sure that the Launchpad works correctly.

    Another possible debug you can do is to sniff the data sent out by the launchpad by using e.g. USB to serial cable and use coolterm (google it-it is basically a hyperterminal program but you can view the data in hexadecimal format).


  • Hi Leo,

    I'm not sure if I have other MSP430 available. I'll check. Maybe someone in e2e have tried it and can confirm that there is no problem with MSP430FR57xx devices.

    Leo Hendrawan said:
    Another possible debug you can do is to sniff the data sent out by the launchpad by using e.g. USB to serial cable and use coolterm (google it-it is basically a hyperterminal program but you can view the data in hexadecimal format).

    I think it's what I have done. See logic.jpg in the first post.



  • Hi Nicolas,

    I just tried using the launchpad BSL scripter setup from slaa535 with an MSP-EXP430FR5739 Experimenter's board and it worked for me. Here is a description of my setup:


    Launchpad Rev 1.4 with a G2452 (this was the value line part I happened to have lying around). All jumpers on J3 and J5 are in place.

    MSP-EXP430FR5739 board - all jumpers on J3 removed, and I am not using the mini USB port (I'm powering the board from the launchpad).


    MSP-EXP430G2 MSP-EXP430FR5739
    P1.6 P2.0
    P1.7 P2.1
    P1.4 RST (on J3, bottom pin)
    P1.5 TEST (on J3, bottom pin)
    Vcc Vcc
    Gnd Gnd


    • I loaded the code from slaa535 onto my G2452 (with project setting changed for G2452 since that was what I had).
    • I disconnected the Launchpad USB from the PC and made the connections listed above with jumper wires
    • Plug in the USB from the Launchpad USB to the PC. After a second both the red and green LEDs should light steadily. This means that the BSL entry sequence was successful.
    • If the LEDs are toggling on the Launchpad or only the red one comes on, then the BSL was not entered properly.
    • You can also tell the BSL was entered if you already have blinking LED code on the MSP-EXP430FR5739 board - if the BSL is entered, no LEDs should be blinking because the application should not be running.
    • Check the COM port your MSP430 Application UART for the Launchpad is enumerated as, and change your script.txt accordingly to match. Note that the BSL Scripter may have issues with two digit COM port numbers.
    • Now run the BSL_Scripter. I used this script:
      MODE 5xx COM2
      RX_DATA_BLOCK FR5739_test.txt
      and this TI-txt file for a program that blinks LED7 on the MSP-EXP430FR5739: 
      1A 14 3F 40 00 00 3F 90 01 00 22 28 3F 40 00 00 
      3F 90 01 00 1D 28 3A 40 00 00 3A 80 00 00 3A 50 
      07 00 5A 09 39 40 00 00 3C 49 3D 49 CF 0D 0F 18 
      4F 5F 00 18 4F DC 6F 4F 4F 4F 5F 06 00 18 5B 4F 
      00 00 1C 53 0D 63 3E 49 3F 49 4B 13 1A 83 EC 23 
      3F 40 00 00 3F 90 00 00 08 24 3A 40 00 00 02 3C 
      6A 13 2A 52 3A 90 00 00 FB 23 19 16 10 01 B2 40 
      80 5A 5C 01 F2 D0 40 00 22 02 F2 D0 40 00 24 02 
      F2 E0 40 00 22 02 1E 14 3D 40 44 28 1E 43 1D 83 
      0E 73 FD 23 0D 93 FB 23 1D 16 03 43 F1 3F 03 43 
      31 40 00 20 B0 13 BA C2 0C 93 02 24 B0 13 00 C2 
      0C 43 B0 13 6E C2 B0 13 BE C2 1C 43 10 01 03 43 
      FF 3F 
      A0 C2 
      and this TI-txt file that comes included with slaa535:
      A5 02
    • After running the script, the application we just loaded into the FR5739 should run and start toggling LED7 - then you know this was successful.

    Note: I did have issues with specifically the TX_BSL_VERSION command, but it was not giving me the error you saw, it just wasn't returning a version # that the scripter recognized. I'm looking into this.

    Please let me know if you can get it to work on your MSP-EXP430FR5739 board with this setup.



  • Hi Katie,

    I did  about the same thing but I used the G2553 instead of the G2452. I will retry with the G2452 and your script.

    I'll give you some news if it works for me.

    Thank you very much !


  • Hi Nicolas,

    I had a quick thought - which Rev. of the MSP-EXP430G2 do you have? I was using Rev. 1.4 but if you have Rev. 1.5 the J3 connections have changed slightly concerning the UART. See table 1 of the Launchpad User's Guide. You can see the launchpad revision in the silkscreen below where it says "EMULATION MSP-EXP430G2" on the board.

    The code in slaa535 was written for a part that does not have a hardware UART (USCI), but rather uses a software UART. So if you are using the Rev 1.5 launchpad, you will need to make sure that you have the jumpers for TX and RX on J3 connected in the horizontal orientation for software UART, as described in the  Launchpad User's Guide section 4.3, regardless of whether or not you are using a G2553 or a part without USCI, because the app note code is written to use the software UART.

    If you have a Launchpad Rev 1.4 or older, then the jumpers should just be in the normal vertical position.



  • Hi all,

    yes unfortunatelly the SLAA535A is made for MSP430G2231 on the Launchpad, i used Launchpad 1.4, and i didn't know that starting Launchpad 1.5 it is shipped with MSP430G2553 instead.

    However there is a code for MSP430G2553 here: http://e2e.ti.com/support/microcontrollers/msp43016-bit_ultra-low_power_mcus/f/166/p/209340/741073.aspx#741073


    did you use the code above? or did you only flash the binary file? if you only flash the binary file to G2553, it won't work since it is basically built for G2231. You should use the code in the link above, and compile it with e.g. IAR Kickstart which is free, or CCS free code size limited.