This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

MSP430F2132 development on rdk-value-sb using IAR

Other Parts Discussed in Thread: RDK-VALUE-SB, MSP430F2132

Hi 

I am developing MSP430 firmware on rdk-value-sb using IAR and TI's reference code. I have no issue building the code but I have issues on downloading  the newly built binary onto the target flash.

I modified the SB button and some initial setting by "download and debug" , IAR told me and it seemed to be fine.

Sun Jan 11, 2015 23:17:04: Using license: Standalone license - IAR Embedded Workbench for Texas Instruments MSP430, 8K KickStart Edition 6.20
Sun Jan 11, 2015 23:17:04: Firmware version 3.4.3.4
Sun Jan 11, 2015 23:17:04: Interface dll version 3.4.3.4
Sun Jan 11, 2015 23:17:06: Device : MSP430F2132
Sun Jan 11, 2015 23:17:06: External voltage : 0.1 V
Sun Jan 11, 2015 23:17:06: VCC voltage : 0.0 V
Sun Jan 11, 2015 23:17:06: Warning: Download and debug with attach to running target option.
Sun Jan 11, 2015 23:17:06: Download completed and verification successful.
Sun Jan 11, 2015 23:17:06: Loaded debugee: C:\EMBRACE\Projects\Vivaldi\RDK-VALUE-SB-RELEASE-v1_20141217\MSP430\Debug\Exe\SoundbarCode.d43

However when I cycled power the device (by instructions) the MSP430 just worked like untouched. So I am not sure my programming is successful. I also try to disable the "attach to the running target" ana IAR told me below:

Sun Jan 11, 2015 23:27:03: Interface dll version 3.4.3.4
Sun Jan 11, 2015 23:27:05: Device : MSP430F2132
Sun Jan 11, 2015 23:27:05: External voltage : 0.1 V
Sun Jan 11, 2015 23:27:05: VCC voltage : 0.0 V
Sun Jan 11, 2015 23:27:05: Could not erase device memory : (Erase) , type=0x2, address=0x1000, length=0x100
Sun Jan 11, 2015 23:27:05: Could not erase device memory : (Erase) , type=0x2, address=0x1000, length=0x100
Sun Jan 11, 2015 23:27:06: Could not erase device memory : (Erase) , type=0x2, address=0x1000, length=0x100
Sun Jan 11, 2015 23:27:06: Could not erase device memory : (Erase) , type=0x2, address=0x1000, length=0x100
Sun Jan 11, 2015 23:27:07: Could not erase device memory : (Erase) , type=0x2, address=0x1000, length=0x100
Sun Jan 11, 2015 23:27:08: Could not erase device memory : (Erase) , type=0x2, address=0x1000, length=0x100
Sun Jan 11, 2015 23:27:10: Could not erase device memory : (Erase) , type=0x2, address=0x1000, length=0x100
Sun Jan 11, 2015 23:27:10: Trying to initialize target failed
Sun Jan 11, 2015 23:27:11: Fatal error: Closing debug session Session aborted!
Sun Jan 11, 2015 23:27:11: Failed to load debugee: C:\EMBRACE\Projects\Vivaldi\RDK-VALUE-SB-RELEASE-v1_20141217\MSP430\Debug\Exe\SoundbarCode.d43

Please help to let me know what setting I was doing wrong, any additional setting I need to add or is it related to IAR version? I need to develoMSP430 firmware and confirm my adjustment on TI's reference design rdk-value-sb.

Thanks inadvance,

Peng

  • Hi TI experts,

    I try to program MSP430F2132 but I failed to erase its memory by IAR, any suggestion?

    Peng
  • I'm not familiar with IAR, but I wonder why it reads External voltage 0.1V, VCC voltage =0.0V. If that means what I think it does, then your target MSP is unpowered. And can't be flashed.
    IIRC, the 'attach to running target' means that you don't upload the firmware, but only load the data into the debugger and attach to the target that is assumed to have the code already loaded and is running it.

    Check the supply voltage jumper settings on the board (if any). The FET is designed to either adjust to the VCC of a self-powered board or provide a supply voltage to the target, but in your case, neither way seems to be active.

    Also note that IAR has a built-in CPU simulator. be sure to use the 'emulator' (the FET and therefore the real target)